Why Mount in Windows shows success but no label in explore?

yes, nobody uses the b: anymore, that is why i use it for mounting my vss backups and rclone.

there was a time, when i was a teenager working for tandy/radio.shack, 12" floppy drives were so expensive and finicky, that read/write heads would go out of alignment.
i would connect the drive to an oscilloscope and realign the head

and there is this

Since we're on the topic of Windows mounts...

Does everyone's mount show 1.00 PB as the total available size? In the early days of Rclone, it used to show 1.00 EB, but that changed at one point (about a year and a half ago, if I had to guess). It could, of course, very well have something to do with a change in WinFSP rather than Rclone. Just wondering.

yes, free space is 1.00PB


Then I have to wonder, what happens when we go over...

Your Gdrive storage becomes sentient... probably...

i remember that episode well.

I am experiencing the same difficulty as the original poster.
If I use an elevated command prompt to start the service, it will be successful and I can see the service running, but the Drive will not show up in File explorer.

If I use a regular command prompt to start the service, I get the following error :
Can't open service! Openservice(): Access is denied.

So it would seem I need higher privileges, but I have no idea how to run a command prompt using the SYSTEM account and when I googled it, I am not able to find any working solution.

Has anyone else had the same problem and solved it?

hello and welcome to the forum,
i think that i gave you the solutions up above in this very post,

  1. https://support.microsoft.com/en-us/help/3035277/mapped-drives-are-not-available-from-an-elevated-prompt-when-uac-is-co


  1. run the rclone mount command as system user.
    you can create a task in task scheduler and run it as system user.

Thanks for getting back to me!
I had seen your proposed solution #1, but to be honest, I am not very tech savvy and I do my best not to try solutions when I don't understand what I am doing, like modifying registry entries.

Your solution #2 seems much more straight forward to me in the sense that I at least understand some of it. I tried creating a task with SYSTEM user.
I selected computer startup as the trigger.
For actions, I selected a batch file with a simple command : C:\rclone\nssm start rclonemount
(rclonemount being the name of the service I created previously using nssm. I also made sure that service is on manual startup).

Now when I restart my computer, nothing happens. The service is still on manual startup and there is no status.

Thank you for your help and I am sorry if this all seems very simple for you. I'm doing my best to work it out with what little I know.

  1. i do not use nssm. but for sure, you can run a service as system user.
  2. no point to create a task in task scheduler to run nssm.
    think about that. use one or the other.
  3. instead, create a .cmd batch file that runs the rclone.exe mount command and create a task for that.
  4. for testing, it is not reasonable to keep restarting the computer to test the task in task scheduler.
    just create the task and run it manually via the GUI or you can create another .cmd batch file to start the task manually like this.
    schtasks /run /tn "rclone\veeam_runbackup_en07.veaamfull"

@ asdffdsa
Thanks for the quick answer.
I just tried what you proposed (rclone.exe mount) and it works almost perfectly!
The only problem I see is that since my config is password protected, I need to include it in the batch file, which means leaving my config password in plain text. How do you deal with this, or do you feel it is no problem?

glad you got it working.

well, i am very paranoid and i do have a solution for that, but it is most complicated.

why not post this as a new question and see how people respond

Here it is : Rclone mount via batch file - hiding config password
Just in case you want to follow it too :slight_smile:

Well wow. This was a valuable gem for me to randomly come across! I had no idea this was possible, so thank you for the information. :slight_smile:

You mention 1MB in your wiki. Do you use 1GB or 1MB? Out of curiosity, why use a dedicated partition? I assume I could just use an existing drive letter and a subfolder?

hi freds,

yeah, mounting to subfolders is very useful.

i have my own backup script, 300+ lines of python code:
it can backup a folder to a local server using fastcopy
it can backup a folder to cloud using rclone
it can compress a folder to a 7zip and copy that to a local server and/or cloud.

about the dedicated partition.

  1. if your computer has only a c: drive, and you want to create the VSS snapshot, you would have to mount it to a subfolder on the same c: drive, such as c:\snapshot, and i find that confusing and can lead to bugs so i mount it as a subfolder of the b: drive.
  2. i run my python script on a lot of desktops and servers and i cannot know ahead of time which drives letters are in use and do not want to tweak my script per computer.
    so i create the b: drive, which is never in use anymore.

as a side note, you can also mount a external usb drive as a subfolder, instead of assigning it a dedicated drive letter.

as for the size of the dedicated partition, i do not store any data in it, just mount points, which take up no space, perhaps 1MB would work but my b: is 1GB

I figured I'd try this, so I made myself a b: drive and a couple of subfolders. I'm not looking to use VSS snapshot, but I do want to have my different mounts as subfolders on the b: drive. It just saves on mounted remotes "clutter".

However, I got an error message with this attempt. Any ideas?

2019/12/10 21:12:40 DEBUG : rclone: Version "v1.50.2" starting with parameters ["C:\\ProgramData\\chocolatey\\lib\\rclone.portable\\tools\\rclone-v1.50.2-windows-amd64\\rclone.exe" "mount" "gd:" "b:\\gd\\" "--allow-other" "--buffer-size" "128M" "--log-level" "DEBUG" "--poll-interval" "15s" "--timeout" "1h"]
2019/12/10 21:12:40 DEBUG : Using config file from "C:\\Users\\Username\\.config\\rclone\\rclone.conf"
2019/12/10 21:12:40 DEBUG : Google drive root '': Mounting on "b:\\gd\\"
2019/12/10 21:12:42 DEBUG : Adding path "vfs/forget" to remote control registry
2019/12/10 21:12:42 DEBUG : Adding path "vfs/refresh" to remote control registry
2019/12/10 21:12:42 DEBUG : Adding path "vfs/poll-interval" to remote control registry
2019/12/10 21:12:42 DEBUG : Google drive root '': Mounting with options: ["-o" "fsname=gd:" "-o" "subtype=rclone" "-o" "max_readahead=131072" "-o" "attr_timeout=1" "-o" "atomic_o_trunc" "-o" "uid=-1" "-o" "gid=-1" "--FileSystemName=rclone" "-o" "volname=gd" "-o" "allow_other"]
Cannot create WinFsp-FUSE file system: mount point in use.
2019/12/10 21:12:42 ERROR : Google drive root '': Mount failed
2019/12/10 21:12:42 Fatal error: failed to mount FUSE fs: mount stopped before calling Init: mount failed

delete the subfolder gd, rclone will create it on the fly and delete it when you exit rclone.

You're a magician. That did the trick - thank you!

sure, glad to help