Webdav Magentacloud does not mount

What is the problem you are having with rclone?

Magentacloud is not mounted at all. This cloud storage provider uses webdav backend.

Run the command 'rclone version' and share the full output of the command.

rclone v1.58.0-beta.5923.b55575e62

os/version: debian 11.2
os/kernel: 5.10.0-10-686-pae (i686)
os/type: linux
os/arch: 386
go/version: go1.17.5
go/linking: static
go/tags: none
but same problem occurs also with rclone v1.57.0

Which cloud storage system are you using? (eg Google Drive)

Other cloud storage providers I use (Mega, Google Drive, Yandex) can be mounted without problems.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Description=RClone mount storage at t-online.de


#Set up environment

ExecStart=/usr/bin/rclone mount T-Online: "${MOUNT_DIR}"
ExecStop=/bin/fusermount -uz "${MOUNT_DIR}"


The rclone config contents with secrets removed.

type = webdav
url = https://webdav.magentacloud.de
vendor = other
user = secret1
pass = secret2

A log from the command with the -vv flag

systemctl status rctonline
â—Ź rctonline.service - RClone mount storage at t-online.de
Loaded: loaded (/etc/systemd/system/rctonline.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2022-01-06 22:58:15 CET; 48s ago
Main PID: 7902 (rclone)
Status: "[22:58] vfs cache: objects 0 (was 0) in use 0, to upload 0, uploading 0, total size 0 (was 0)"
Tasks: 10 (limit: 4915)
Memory: 15.0M
CPU: 367ms
CGroup: /system.slice/rctonline.service
└─7902 /usr/bin/rclone mount T-Online: /srv/backup/t-online.de --allow-other --syslog --cache-dir=/srv/backup/.cache/t-online --drive-use-trash=false>

Jan 06 22:58:14 systemd[1]: Starting RClone mount storage at t-online.de...
Jan 06 22:58:15 systemd[1]: Started RClone mount storage at t-online.de.
lines 1-13/13 (END)

/srv/backup/t-online.de# ls -l
total 0

hello and welcome to the forum,

need to see a rclone debug log before calling this a rclone bug......

what is the output of
rclone ls T-Online:

Hello, I've just executed the requested command:
root@something:~/.config/rclone# rclone ls T-Online:
so no output at all.

i meant to run
rclone ls T-Online: -vv

and are you use that webdav.magentacloud.de is up and running???

Oh, sorry! Here you are!

root@something:~/.config/rclone# rclone ls T-Online: -vv
2022/01/06 23:56:54 DEBUG : rclone: Version "v1.58.0-beta.5923.b55575e62" starting with parameters ["rclone" "ls" "T-Online:" "-vv"]
2022/01/06 23:56:54 DEBUG : Creating backend with remote "T-Online:"
2022/01/06 23:56:54 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2022/01/06 23:56:54 DEBUG : found headers:
2022/01/06 23:56:54 DEBUG : 5 go routines active

well, that is a beta version of rclone, is there a specifc reason to use that?

are you use that webdav.magentacloud.de is up and running???
please login in and make sure your files are there

I have also tried rclone 1.57.0 before. No directory listing at all also with this version, however with 1.57.0 I got the following error at /var/log/syslog:
Jan 5 23:52:15 MYHOSTNAME rclone[12973]: webdav root '': Statfs failed: about call failed: XML syntax error on line 34: invalid character entity & (no semicolon)
A related forum post has suggested for this error to upgrade to the latest beta version.

Logging in at https://cloud.telekom-dienste.de/ I can browse my directories and files as usually.

is that webdav server address working?
type it into your web browser and i think you will get a suprise...

No, it is not working:
Ihre MagentaCLOUD wird gewartet...
Die MagentaCLOUD hat ein Update bekommen und ist leider gerade nicht erreichbar...

Wir arbeiten mit Hochdruck daran, dass Ihnen der Zugang zur MagentaCLOUD bald wieder zur VerfĂĽgung steht.
Bitte haben Sie noch etwas Geduld.

Aktuelle Informationen zur neuen MagentaCLOUD

yes, that is the surprise i wrote about.

but what matters is; yet another alleged rclone bug bites the dust!

Oh, sorry! One - two weeks ago after accessing my data on the other web interface I have thought that they must be ready. I also upgraded my debian during this period from buster to bullseye and I have supposed that somehow is related to the new debian version. Hopefully will be OK after they end with the maintenance.
Can be closed than.

I have found the following on their site:

WebDAV Address

*With the WebDAV address, you can set up your MagentaCLOUD as a network drive on Windows, for example. You can find more information about WebDAV and how to use it here.

It seems that webdav address has been changed.

ok, good to know

Now my systemd service starts. I also changed back to rclone 1.57.0 Still no directory listing, but when executing aolah76@freemail.hu
I get the following:
2022/01/08 12:19:32 DEBUG : rclone: Version "v1.57.0" starting with parameters ["rclone" "ls" "T-Online:" "-vv"]
2022/01/08 12:19:32 DEBUG : Creating backend with remote "T-Online:"
2022/01/08 12:19:32 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2022/01/08 12:19:32 DEBUG : found headers:
2022/01/08 12:19:57 ERROR : : error listing: couldn't list files: Username or password was incorrect, No 'Authorization: Bearer' header found. Either the client didn't send one, or the server is mis-configured: Sabre\DAV\Exception\NotAuthenticated: 401 Unauthorized
2022/01/08 12:19:57 DEBUG : 3 go routines active
2022/01/08 12:19:57 Failed to ls with 2 errors: last error was: couldn't list files: Username or password was incorrect, No 'Authorization: Bearer' header found. Either the client didn't send one, or the server is mis-configured: Sabre\DAV\Exception\NotAuthenticated: 401 Unauthorized

I have tried reconfiguring rclone with default bearer token and with one generated password by the magenta site.

What do I wrong? Or better opening a ticket by magenta if possible?

when you log into the web interface, what do you use for the password?
the actual password or the bearer token?

as you did not post your failed attempts, cannot offer better advice.

imho, there are only a few possible combinations to test.
the username is the username, so that is a constant.
then there are the password and bearer token
i would test in the following order

  1. password = password

  2. password = bearer token

  3. password = password
    bearer token = bearer token

1 Like

Strange, but the 2nd option, ie. password = bearer token IS WORKING!
But copying the bearer token directly to rclone.conf is NOK.
Running rclone config than editing related config (in my case T-Online) and entering the bearer token as password when requested is OK.
Bearer token is than stored in encrypted way in rclone.conf
Starting my systemd unit rctonline starts as used to.
Running rclone ls T-Online: -vv finally I got a list of my files and directories.
Checking in Midnight Commander is also OK.
Thank's your great support!

not so strange, common problem in the forum, and luckily a simple solution.

the main thing - another alleged rclone bug that has bit the dust!

did you compare the actual password and the password in the config file?
they are not the same, as rclone obscures the password.

so if you want to paste the password into the config file.

  1. obscure the password
  2. paste the obscured password into config file
rclone obscure supersecretpassword

Hello, the token I generated at magenta and which is present in rclone.conf after running the rclone config command, does not match. I did not check it with rclone obscure because I do not remember the generated token :frowning:

the password from magentcloud will will not match the obscured password in the rclone config file.

sorry, confused, what is the problem?

From my side, now there is no problem. The bearer token entered as password when running rclone config works.