Sync to Proton Drive never finishes

What is the problem you are having with rclone?

I have a folder which i currently want to sync to Proton Drive.
It has about 30K files, with a total of 45GB.
When i first ran rclone, it seems to have synced fine.
But, now, any time after that, when i run rclone again, to sync just a few files (sometimes just 1 or 2 new files) it never finishes.
I have been told to run the rclone sync command with "-P -v", and the output is just this:

Transferred:              0 B / 0 B, -, 0 B/s, ETA -
Checks:             21646 / 21646, 100%
Elapsed time:    1d1m33.4s

The elapsed time just keeps going up... the "checks" seem to grow, VERY slowly... but as you can see, after more than 24h, it had only "checked" 21646 files... whats going on?

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.2

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 6.5.0-15-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.6
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Proton Drive (With an encrypted layer)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync -P -v /home/myfolder ProtonEncrypted:  
(I have also tried with --fast-list)

The rclone config contents with secrets removed.

[Proton]
type = protondrive
username = xxxx
password = xxxx
2fa = xxxxxx
client_uid = xxxx
client_access_token = xxxx
client_refresh_token = xxxx
client_salted_key_pass = xxxx

[ProtonEncrypted]
type = crypt
remote = Proton:Backups/Encrypted
password = xxxx
password2 = xxxx
filename_encryption = obfuscate

A log from the command with the -vv flag

Transferred:              0 B / 0 B, -, 0 B/s, ETA -
Checks:             21646 / 21646, 100%
Elapsed time:    1d1m33.4s

hi, did you this post, from yesterday?

there have been many issue with proton drive, including syncs that never finish.
to see what is going on, use a rclone debug log.