Rclone has been banned from Amazon Drive


#1

For reasons as yet unknown rclone has been banned from Amazon Drive.

All attempts to get tokens are met with “Client authentication failed: invalid_client”. And you’ll find rclone has disappeared from your authorized apps in your Amazon account.

This only affects Amazon Drive, it doesn’t affect any of the other cloud providers that rclone supports.

Amazon haven’t been returning either my calls or emails so I don’t know exactly why this has happened or whether it is possible that the ban will be reversed - I will update this post if and when I learn more.

Nick

Update 2017-05-20

I have now heard back from Amazon. Rclone has been banned for having the encrypted secrets in the source code.

I’ve asked for new credentials so I can build an auth server and get rclone going again - I haven’t heard back on that reply yet, but it is plausible we could get rclone running again with Amazon Drive in the not too distant future.

Thank you all for your patience

Update 2017-05-30

I’ve finally heard back from Amazon about my request for new developer credentials (after 10 days!) to build an auth server

We have ended the Amazon Drive API and SDK invitation period to focus on enabling new customer experiences with current developers. Should this change, we will provide an update on our developer website: https://developer.amazon.com/amazon-drive

So I guess that is a no :frowning:

Update 2017-07-02

See this forum post for a workaround.

Update 2018-07-09

That workaround no longer works. Unless you have your own API keys for Amazon Drive you can’t use it with rclone - sorry :frowning:

If you happen to know anyone who works at Amazon then please ask them to re-instate rclone into the Amazon Drive developer program - thanks!

Nick


My response to Amazon banning rclone
ACD BAN/Alternatives discussion (error HTTP code 429)
#2

#3

Because of PLEX users?


#4

Hi there,

Has it got something to do with the acd_cli_oa getting banned a couple of days ago, because of a token bug which could expose data from other users?

I found this item on reddit this morning when I realized Amazon wasn’t connecting anymore.


#5

If we were to fork rclone and just re register it as a different developer would that be robust against this sort of thing? As far as I can tell it seems like Amazon wants all app developers to be a part of the auth process as though security through obscurity actually worked. Maybe we could all register our own forks with the only change being a different app name and separate auth?


#6

thanks for the update @ncw.

This is really fucking shady from Amazon. It’s fair enough they can pick and choose who they want to be their customers, and which apps are accessing their services but what’s up with just cutting it and not saying anything? How about letting people know, setting a period of time in which they can grab their data back, and then killing it.

Haven’t had a chance to test Arq which I also use with ACD, but I’ll definitely be asking for my money back if they have just started blanket banning these third party apps.


#7

Arq stopped working for me this morning, but I just checked and it’s back.


#8

I just do not understand the reson of ban. It is just a software and ACD suppose to be serving it. They could have limit bandwidth but no logical reason for banning whole software.


#9

Unfortunately Amazon seem to have stopped people signing up for the app program. (You can no longer create a security profile with Web access). You have to join a private beta now which I’ve had no success in joining.

Before amazon stopped that, you would have been able to get your own app id and secret and use rclone with them (just like you can with Google Drive).


#10

Sad times, hopefully rclone will try to push local cache faster now so we can avoid google bans with rclone gdrive mount.





#11

Thanks for the official update. Guess ‘unlimited’ didn’t mean ‘unlimited’ after all (it never does).

Back to GDrive then… :slight_smile:


#12

@ncw Now i use Rclone my own code, without any problem.

My question, what do you think, it is possible that Amazon ban my secret code, if i use it actively? (but only just me, i dont want to share my code)

And please dont delete acd option your future release, because some of able to use it, with own code :slight_smile:

Best if you add a line with your README that it only work with own secret code.


#13

in what place in source are you changing this code and what is required on account to do to have it working?


#14

It need to register a new ACD connection and add you own secret code. It need a old developer account/secret code (about 2 years old)


#16

I’m at the same time sad for the other rclone users still using ACD, and glad that I myself never paid a single dime to Amazon for their sucky cloud (I cancelled the service when I was still in the trial phase).

I thank @ncw for pursuing the reasons for the Amazon deletion of rclone even if I myself do not use (not plan to ever use) their service, because that could help rclone to eventually avoid the same fate on other services like GDrive.


#17

What Amazon is doing is very unfair. Is there a way I can contact support? Do you have the link? I want to write them to ask for refund.


#18

So assuming this is gone for good it is time for an alternative. However: I was using an encrypted rclone “path” on ACD. So while I might be able to download the files from Amazon, I cannot easily decrypt it to then upload it to GDrive.

@ncw Is there any workaround you can suggest how I could decrypt those files once I downloaded them from ACD via the web-interface? Otherwise I just lost 1 TB of “live” data… That would be a real pain…


#19

@Jan-Peter_Koopmann, I had this same issue. I am downloading the encrypted folders (using odrive) to a Google Cloud instance and then will rclone them plain to a folder on GDrive. I will then use rclone to mount that encrypted folder on my computer once again (using the same credentials from rclone.conf).
I’ve tested with a small folder and worked very well. See here for further discussions: Recommendations for ACD->GSuite/Other transfers


#20

Just point your current crypt drive to location the the files thats it.
Change rclone.conf

OLD

[acdcrypt]
type = crypt
remote = acd:/encrypted
filename_encryption = standard
password = xxx
password2 = xxx

NEW

[acdcrypt]
type = crypt
remote = /home/myuser/encrypted
filename_encryption = standard
password = xxx
password2 = xxx

Now you see all encrypted files there eg rclone ls acdcrypt: ( or whatever name you used ) and you can also mount it egrclone mount /mnt/unencrypted acdcrypt: ,


#21

I received below response… I thought I’d share this email with you all
Last sentence " We appreciate your patience and understanding as we work to resolve this issue."
Revoked as a temporary or forever kinda action?

Customer service associates does not have any information why this has been revoked. GO HOME! :wink:

[Amazon Drive Customer Service]

Sincere apologies for the inconvenience caused in this regard.

I understand your concern about using third party clients or apps to access Amazon drive.

Rclone app access has been revoked and it no longer supports Amazon Drive access.

Currently, we as customer service associates does not have any information why this has been revoked.

It is always important for us to hear how customers react to all aspects. Your valuable feedback will help us to improve the selection and service we provide and we’re glad you took time to write to us. We do value the feedback of our customers and make every attempt to integrate their comments or suggestions into our stores and procedures.

In the meanwhile, try using Amazon Drive Desktop application for Windows / Mac or use Amazon Drive website for other OS devices.

We appreciate your patience and understanding as we work to resolve this issue.