Google Drive, Plex, Windows 10

it depends on the exact version of rclone.

there are many posts in the forum about rclone, mount and plex.

I thought I'd chime in here, since this is about Windows :wink:. Note that this is pretty much a copy/paste from a previous post of mine:

I've been using Windows to host Plex and the Gdrive mount on a dedicated server for about three years now, with almost no issues at all. The few times I had a problem watching at home was due to my ISP's peering with Google at the time. My dedicated server has gig speed up and down, but my home connection is 500/500. I can watch even the largest 4K remuxes without buffering.

Make sure you have installed WinFsp before you try to use a mount with Rclone. You can get WinFsp here: https://github.com/billziss-gh/winfsp/releases

I suggest you try my mount settings. Note that this is a read-only mount. Create a .bat file with the following (replace my path and drive name with your own, of course):

@echo off
title Rclone Mount READ ONLY
D:\Programs\Rclone\rclone mount --attr-timeout 1000h --dir-cache-time 1000h --poll-interval 0 --rc --read-only -v Google_Drive_Crypt: G:
pause

Then create another batch file with this (replacing my path again):

@echo off
title Rclone Prime
D:\Programs\Rclone\rclone rc vfs/refresh recursive=true --timeout 10m
pause

Run this after you mount the drive to "prime" it. This will basically cache the file and folder structure for much, much faster reading afterwards, and it does so very quickly. You'll want to re-run this whenever you make changes to your mount.

To give you an idea of how I use all this: I download stuff overnight, organize everything and then use RcloneBrowser by @kapitainsky to upload everything to Gdrive. I do not upload via mount, ever, hence the read-only. Once uploaded, I use a separate read/write mount to move things around in Gdrive. For this, I use this very simple command via batch file (notice the different drive letter):

@echo off
title Rclone Mount READ/WRITE
D:\Programs\Rclone\rclone mount -v Google_Drive_Crypt: F:
pause

When I'm done putting things into their final locations, I stop the read/write mount via CTRL+C. Then I run the "prime" batch to update the read-only mount. Once that's done, I run the Plex scan.

As you can see, I like doing things manually and being in full control at all times :wink:

EDIT: Note that my solution does not use any cache. My Internet speeds on both the server side and at home do not require things to be cached. Media starts playing after about 3-5 seconds.

2 Likes

hi @VBB,

when the OP posted, my first thought was you and your post but i like to give the OP a chance to search around the forum first.

Wait, you mean people actually use SEARCH???? :rofl:

3 Likes

Thank you this is perfect, exactly what I've been looking for, love the priming bit too

the prime part of it doesnt seem to be working just hangs on the cmd screen

heres what i have

mount.bat

@echo off
title Rclone Mount READ ONLY
C:\rclone\rclone mount --attr-timeout 1000h --dir-cache-time 1000h --poll-interval 0 --rc --read-only -v Gdrive: V:
pause

Prime.bat

@echo off
title Rclone Prime
C:\rclone\rclone rc vfs/refresh recursive=true --timeout 10m
pause

you can run the same command with debug output by adding flag -vv
C:\rclone\rclone rc vfs/refresh recursive=true --timeout 10m -vv

thats with your command

the prime command can take time to complete, as it has to scan all the files in all the folders and subfolders.

here is the output of my prime command

2020/09/16 18:49:24 DEBUG : rclone: Version "v1.53.0" starting with parameters ["C:\\data\\rclone\\scripts\\rclone.exe" "rc" "vfs/refresh" "recursive=true" "-vv"]
{
	"result": {
		"": "OK"
	}
}
2020/09/16 18:49:27 DEBUG : 4 go routines active

my output

VBB command uses flag --timeout 10m

if you look at your command's timestamps, the command timed-out after 10 minutes - 23:58 to 00:08

change the flag to --timeout=0 to disable a timeout period.
run the command again.

Hmm, that is odd, unless he has even more data than I have. I recently started using the timeout flag, because my priming started taking longer than the default would allow. You could remove the flag entirely and see if it makes a difference. Just to be sure, your mount is up while you're running the prime.bat?

yes, i noticed that you added that flag, as i do not remember it from your posts.

i would not remove the flag, as The default is 5m. Set to 0 to disable.

I started having an issue after updating to the latest beta one day, and Nick recommended using the timeout flag. That fixed my problem. You could set it to an hour even, and it wouldn't make a difference, if your prime command connected properly. But in OP's case it's not connecting, so it simply times out after 10 minutes.

good point but based on docs, not sure that is correct.
If a transfer has started but then becomes idle for this long it is considered broken and disconnected

so the transfer/process can start, but if the command does not finish in x minutes, then it is considered a failed command.

to know, the OP should make sure the mount command is working.
then run the command with --timeout=0, wait and see what happens.

if the mount is not running or the refresh command cannot connect, it fails immediately .
Failed to rc: connection failed: Post "http://localhost:5572/vfs/refresh": dial tcp 127.0.0.1:5572: connectex: No connection could be made because the target machine actively refused it

Right, that's why I was wondering if he had even more data, so the command would take even longer to finish. Disabling the timeout or setting it to a really high number should take care of it, but of course only if RC is working properly. We'll have to wait for OP to respond :slight_smile:

:upside_down_face:

yep mount is running whilst i do this, i have about 400tb plus of data so could probably take some time i have now set it off so with --timeout 0m we shall see if it finishes

it completed just took 32mins