Mounted the dropbox as a drive but it's not being recognized in Plex

What is the problem you are having with rclone?

Mounted the dropbox (with WinFSP v.1.8.20304) as a drive but it's not being recognized in Plex. It works perfectly on its own. I can see in My PC along with other drives and access and put files in it. But the plex just doesn't see the drive letter when I try to add it as library.

What is your rclone version (output from rclone version)

rclone v1.53.2

  • os/arch: windows/amd64
  • go version: go1.15.2

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10, 64bit

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount dropbox:/ q: --vfs-cache-mode writes --allow-other

A log from the command with the -vv flag

hello and welcome to the forum,

--allow-other does nothing on windows, so you can remove it.

this is a common problem on windows
as a test, open two command prompts and run dir q: and let us know wha the outputs are?

  • one prompt with adimin rights
  • one prompt without admin rights

Without Admin

Volume in drive Q is dropbox
Volume Serial Number is BDDD-9228

Directory of Q:\

14/11/2020 03:23 PM Kohl Max
14/11/2020 03:23 PM Videos
0 File(s) 0 bytes
2 Dir(s) 1,624,783,032,320 bytes free

With Admin

The system cannot find the drive specified.

ok. good, that is what i expected, but wanted to confirm

here is the problem and solution.

that would mean that you are running rclone without elevated rights.
on windows, it keeps two lists of net shares and mounts.

  • one list for program/services run with admin rights.
  • one list for program/services run without admin rights.

if you run rclone as system user, then all programs/services will see the mount.

  • keep in mind, that rclone will run as system user, not your username, and rclone will not be able to find the config file in its default location, so you must use --config
  • you will not be able to see the command prompt wndow that rclone is running under, so if you want to know what is going on you need to use a rclone log file.

Thank you so much for such quick replies.

Just one question, how would I go about running rclone as system user? Do I need another app to run it through?

  • the easiest way is to use task scheduler.

  • what i do is this and then no need to system user.
    mount to a folder, not drive letter like so.
    rclone mount gdrive-a1b2: b:\mount\rclone\gdrive-a1b2

  • if is recommend to use --vfs-cache-mode full

when i mount for streaming, i follow @VBB recommendations about mounting as read only and priming the mount for plex scan.
Google Drive, Plex, Windows 10

1 Like

That folder solution worked way better!

Thank you so much. I've been trying to fix this issue for entire day now.

sure, no problem

Oh and just one last question, it's my first time setting up plex with rclone so a bit confused

If I restart my computer, do I need to run and resync rclone with my dropobox again?

no, as when plex does a scan, it creates its own local database of metadata.

i always manual scan and i have a very simple script to prime the cache then scan

That's great. It seems rclone is just hard to setup, but when you get it running it runs like a smooth machine :smiley:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.