Google Drive on nfs doesn't work

What is the problem you are having with rclone?

I'm using rclone on a raspberry 4 and I've successfully mounted a Google Drive partition on /mnt/GDrive (I can see files on raspberry), my issues start when I try to access that folder using nfs on my pc, I see it empty on pc.

Run the command 'rclone version' and share the full output of the command.

Here is my rclone version:
rclone v1.61.1

  • os/version: debian 11.6 (64 bit)
  • os/kernel: 6.1.19-v8+ (aarch64)
  • os/type: linux
  • os/arch: arm64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

I'm using Google Drive storage system.

Raspberry configuration:
I've mounted it on my raspberry using systemd (I'm new to these things not even sure if I chose best settings for mount the drive)

Description=Mount GDrive1Crypt

ExecStart=rclone mount --config=/root/.config/rclone/rclone.conf encrypted_gdrive: /mnt/GDrive --allow-other --cache-db-purge --fast-list --poll-interval 20m
ExecStop=/bin/fusermount -u /mnt/GDrive


export file:

/mnt *(rw,async,insecure,no_root_squash,fsid=0,crossmnt,no_subtree_check)

running ls -l on /mnt folders:

drwxr-xr-x   1 root   root      0 Mar 21 11:29 GDrive
drwxrwsrwx+ 21 dietpi dietpi 4096 Mar 15 13:31 Toshiba

tried to chown / chmod but as soon as it mounts the folder owner gets changed to root, not sure if that's the issue

my rclone config file:

type = drive
client_id = x
client_secret = x
scope = drive
token = {"access_token":"x","expiry":"x"}
team_drive = x
root_folder_id = 

type = crypt
remote = GDrive:backup
password = x
password2 = x

Pc configuration:
fstab looks like this:

# This is a disk (not related to rclone) attached to the raspberry and it works correctly	/mnt/Toshiba nfs	defaults 0 0

# This is the rclone fstab entry but it's not working	/mnt/GDrive nfs		defaults 0 0

hello and welcome to the forum,
not sure about the nfs issue

--cache-db-purge --fast-list - these flags do nothing, can remove them.

1 Like

as a test, did you try to change the mount command to run as non-root user.

what happens if you run the mount command from the terminal, not using systemd.

1 Like

Thank you for the tips :smiley: Anyway, I just tried to run the rclone mount command without sudo permission but looks like before.

Running directly the mount command doesn't output anything but it mounts correctly in /mnt/GDrive folder (still root as owner of the folder). On pc I still can't see files inside the nfs mounted folder

add -vv

nfs has been discussed a number of times in the forum, have you searched?

1 Like

Here is the output, seems there are no errrors:

2023/03/21 13:20:59 DEBUG : rclone: Version "v1.61.1" starting with parameters ["rclone" "mount" "--config=/root/.config/rclone/rclone.conf" "encrypted_gdrive:" "/mnt/GDrive" "--allow-other" "--poll-interval" "20m" "-vv"]
2023/03/21 13:20:59 DEBUG : Creating backend with remote "encrypted_gdrive:"
2023/03/21 13:20:59 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2023/03/21 13:20:59 DEBUG : Creating backend with remote "GDrive:backup"
2023/03/21 13:21:00 DEBUG : Encrypted drive 'encrypted_gdrive:': Mounting on "/mnt/GDrive"
2023/03/21 13:21:00 DEBUG : : Root: 
2023/03/21 13:21:00 DEBUG : : >Root: node=/, err=<nil>
2023/03/21 13:21:06 DEBUG : /: Attr: 
2023/03/21 13:21:06 DEBUG : /: >Attr: attr=valid=1s ino=0 size=0 mode=drwxr-xr-x, err=<nil>

yes, but I'm new to linux world and I'm not sure if I do things correctly, I tried other solutions like to specify nfsv4 with command sudo mount -t nfs -o nfsvers=4 /mnt/GDrive but didn't change anything

1 Like

i re-edited that last post. did you see

Yes, I'll try to check it out. ty!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.