remote support?

Has anyone managed to configure as rclone remote?

Although their WebDAV settings work fine on my PC rclone refuses to accept it as a WebDAV remote.

I'm using latest rclone on Ubuntu.

What is more confusing is that I found on Google that bitrix24 was actually supported in rclone at least in the past (with the remote name 'Bitrix Site Manager') but now that option doesn't show up. Not sure what happened with that.

I have 100GB there so any way to make it work would be appreciated

1 Like


what does that mean?

when you posted, you should have been asked for information, such as rclone command, rclone version, rclone config file, rclone debug log.....

No problem it connects now (as WebDAV remote) lol I didn't specify the exact URL .

Sorry for headache

1 Like

ok, glad you got it working..

Just an update:
Connection works, copying single files works, but any action on directories fails with an error : Update mkParentDir failed: 409 Conflict

It seems rclone can't identify directories in the remote.

Hope this can be fixed.

you are not providing any usable information to enable us to help you

when you first posted, you should have been asked for information, such as rclone command, rclone version, rclone config file, rclone debug log.....

Because this problem is not new I see it's also described here with all info:

So this is an old problem still ongoing.
rclone copy/sync fails on directories, such actions also fail on rclone mounts, all with same error. Clearly an rclone issues not some mistake on my part and no easy fix.

I guess fixing this is just a matter of priority by rclone developers.
I'm using latest rclone as mentioned but that doesn't matter much as problem is old enough and already brought to attention. Maybe it's time to fix this.

Have you tried with rclone 1.53.3 ? I think a patch went into that which should fix the problem.

Thanks Nick so I've gone ahead and installed rclone v1.54.0-beta.4971.e45716cac

Now situation is just a little bit better.

First, when I mount bitrix24 I can successfully copy directories with their files into the mount point using Linux commands.

But problems consist when using rclone commands. When I use for example 'rclone copy' I notice an odd behavior: now directories and files are all created on the remote, files 'ls -l' shows the correct size - but content in all files is just a mix of HTML and js. Still command exits with 0 no errors.... very odd.

Command I used:
rclone copy --verbose --transfers 30 --checkers 8 --contimeout 60s --timeout 300s --retries 3 --low-level-retries 10 --stats 1s /root/test bit:/testdir/

By the way Nick according to rclone changelog a similar problem with Bitrix24 was fixed by you in v1.46 already, so apparently it popped up again.

Did the copy to the mount corrupt the files in the same way?

How did you see the files were wrong? Did you download them again with rclone?

Bitrix seems a bit non-standard when it comes to WebDAV.

Do you have an account you could lend me for some testing? Or maybe I can get a free account - I wasn't sure from looking at their website! If you can lend me credentials them private message me here.

Thank you Nick,
After further investigation (this time on PC) files are not corrupt they're OK. Files transfer to remote actually seems fine. Problem is mostly with accessing files for read/write using rclone commands (like rclone cat) or Linux commands on mount point. That's where I was always getting HTML/JS junk from Bitrix site.

For the test I ran 'rclone serve webdav' on the remote then accessed it through PC. I came to know everything was OK with the files I could open them etc (unlike my Ubuntu VPS).

Another thing to know is when I created a Crypt remote inside Bitrix remote then ran 'rclone serve' on the crypt I couldn't open any file at all. All attempts failed with the error "not an encrypted file - bad magic string".

So remote it partially workable, I guess some people may be able to live with the problems for storage etc but since I use crypts and media it's not yet satisfying.

After this better clarification please let me know if you still want to look I can send you credentials.

That is good.

HTML/JS junk is normally an error page. Can you look at it in a browser and see?


I can take a quick look if you want.

Thanks Nick PM sent hope you can make it work properly

1 Like

Thanks for that. I made a new directory in the root called ncw-test

Downloading a file from there did indeed give a pile of HTML/JS

2020/12/22 21:40:06 DEBUG : GET /company/personal/user/1/files/lib/ncw-test/file.txt HTTP/1.1
User-Agent: rclone/v1.54.0-beta.4973.bdc2278a3
Authorization: XXXX
Accept-Encoding: gzip
2020/12/22 21:40:06 DEBUG : HTTP RESPONSE (req 0xc0003f0200)
2020/12/22 21:40:06 DEBUG : HTTP/2.0 200 OK
Cache-Control: no-store, no-cache, must-revalidate
Content-Type: text/html; charset=UTF-8
Date: Tue, 22 Dec 2020 21:40:06 GMT
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Pragma: no-cache
Server: nginx/1.16.1
Server-Timing: t1;dur=0.146, t2;dur=0.147, t3;dur=0.000
Server-Timing: tc1;dur=73125, tc2;dur=69000, tc3;dur=20
Set-Cookie: qmb=1.socservices.1; path=/
Set-Cookie: XXX
Set-Cookie: BITRIX_SM_CC=Y; expires=Fri, 17-Dec-2021 21:40:06 GMT; Max-Age=31104000; path=/
Set-Cookie: BITRIX_SM_NCC=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0; path=/
Strict-Transport-Security: max-age=31536000; includeSubdomains
X-Bitrix-Lb: lb-de-01
X-Bitrix-Ri: XXX
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
X-Powered-Cms: Bitrix Site Manager (XXX)

<!DOCTYPE html>
<html >
<meta name="viewport" content="width=1135">
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta name="apple-itunes-app" content="app-id=561683423" />
<link rel="apple-touch-icon-precomposed" href="/images/iphone/57x57.png" />

As far as I can see it has decided to give rclone back the web browser version of the site, so a a single page application with HTML and javascript.

I'm guessing it is missing some header or user agent.

I don't know if you could snoop on the official client or web interface and see what headers it does send?

Can you ask bitrix support about this? It looks like a bug in the WebDAV implementation to me as a straight forward GET request to the URL returned in the collection should just fetch the file.

Thank you Nick for effort.
They don't provide any support for free accounts unfortunately.

But I checked that HTML error page and it contains a small message
"Das Modul "Dokumentenarchiv" wurde nicht installiert." which translates to "The Document Library module is not installed"...

So I'll try to find a way to get such a module installed through web interface. Can't understand why they have to make everything complicated

Ah, that makes sense because I'm sure people had it working before.

Did you figure it out?

Not yet, just found on Google some reference to modules installation process for their self-hosted setup, but the web interface doesn't look exactly the same.. still there's a good chance I missed something just need more time to dig.

Nick what you're saying is encouraging because I have encountered some cloud services in the past (like Firedrive or Userscloud) which enabled upload-only over WebDAV but I guess it's not necessarily the case here, as you said it properly worked before.

I'll update if I move forward, hope this thread won't get locked. It would be a shame if it didn't work because it's a reliable cloud with very good speeds.

Nick portal can be accessed through that baseurl. Then from the bottom of page can switch to English. Feel free to go wild if you want.

I managed to figure it out I think... Bitrix needs the Depth header otherwise it treats it as a fetch from the web UI.

I don't think this is RFC compliant but it is easy to fix.

Try this

v1.54.0-beta.4977.2e77a1255.fix-bitrix-get on branch fix-bitrix-get (uploaded in 15-30 mins)

1 Like

Sounds great Nick,
I've successfully compiled that branch, added the remote (tried using both 'rclone config' dialog and by importing its rclone.conf section) but remote isn't usable, rclone commands are returning this error:

2020/12/26 17:57:45 Failed to ncdu with 2 errors: last error was: ncdu directory listing: ncdu listing failed: couldn't list files: XML syntax error on line 20: element <a> closed by </td>

Other remotes I tested work well.

Maybe we're almost there thank you

Hmm, it is working for me.

I note that the URL in the email you sent me possibly wasn't the correct one. The one from the drive config on the bitrix site was slightly different

#url =
url =

I don't know if this will make a difference.

Unfortunately is down at the moment otherwise you could try the binary I built...