remote support?

Nick yesterday I couldn't see a general 'linux' precompiled binary on that page so I just compiled the branch (on Ubuntu 18.04 x86_64). No idea why I had that error as compilation went smooth and I could verify that exact branch version successfully installed.

Just tested the other WebDAV URL but no difference (with another rclone version both URLs work).

I see site is back at the moment, could you please add Linux binary? Thanks

I pushed up a new version of the code here. I gave it some testing - I can upload / download directory structures of files now and it seems to be working OK.

v1.54.0-beta.4993.517cb78e2.fix-bitrix-get on branch fix-bitrix-get (uploaded in 15-30 mins)

1 Like

Sorry Nick I don't know what OS you're using. I've just tested the deb amd64 package on 3 different systems: Ubuntu 18, Ubuntu 16 and Debian 9, configured bitrix24 remote (using same steps I emailed you and the correct URL) but unfortunately got the same error.

It seems either your fix conflicts with some OS or maybe you configured bitrix24 in a different way.

If you need I can create an Ubuntu LXC container with root access for you to test.

I'm seeing the same error as you now.

What is happening is that the initial PROPFIND is getting a 302 redirect to Because it is a 302 redirect the http library changes the PROPFIND to a GET as it should and it returns an HTML page. If I make the first page be the groupdav.php URL then it works, but it is no longer the files it is a group calendar application.

So I'm not sure why it would be issuing a redirect like that.

I suspect that they have attempted to block rclone as I noticed if you set --user-agent curl then it all works properly again.

This is using the URL that you get when clicking here


Then here


Then click on "Network Drive"

1 Like

Awesome Nick all rclone commands I tested work fine now with that user-agent flag. Crypt also work. That's great!

BTW only issue I see is with rclone mount.
After mounting bitrix24 with the user-agent flag (without it all commands on mount-point failed with this error: ls: reading directory 'drive': Input/output error ) I could successfully 'ls' the mount point.
I could successfully copy files and directories into mount-point.

But when tried to 'cat' a file inside mount-point or copy files from mount-point to local dir the system hung for some time then threw this error :
C2020/12/29 18:31:25 ERROR : foo: ReadFileHandle.Read error: low level retry 1/10: stream error: stream ID 3; INTERNAL_ERROR

don't know if that's easily fixable, I guess it has something to do with each Linux commands not being wrapped with user-agent, but I don't care much. I'm very satisfied with it now as-is.

Many thanks Nick for your help :slight_smile:

The CRM in Bitrix24 provides a platform to organize and track interaction with potential or existing clients, partners, agents and other contacts. Bitrix24's CRM forms a contact base where the interaction and the history of contacts are managed and stored.

And they don't need the patched version either, they work with rclone v1.53.3 if you are using the --user-agent

That is an http2 stream error I think. Rclone should have retried it though. I think these are caused by some HTTP2 interaction going wrong - we've seen them on google drive but I don't know what causes them.

BTW if you want to set the user agent variable always, you can set an environment variable "RCLONE_USER_AGENT=curl"

1 Like

Nick, patch seems to be helpful, just tested back with rclone v1.54.0-beta.4965.cb16f4207 (the last I used before your fix) but was still getting same HTML/JS errors even with the user-agent flag.

I hope it will be merged with stable version (maybe as a backend for Bitrix24 which makes the best out of it).

Yes you are right, the patch is needed - faulty testing by me.

I've merged it to master now which means it will be in the latest beta in 15-30 mins and released in v1.54

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.