Unable to Authorize with pcloud

What is the problem you are having with rclone?

I seem to have lost my token access (revoked). Now trying to re-gain access

Unable to run 'rclone authorize pcloud' which used to work previously.

Now getting red message error 'Invalid_clientid'.

What is your rclone version (output from rclone version)

rclone v1.56.0

  • os/version: ubuntu 18.04 (64 bit)
  • os/kernel: 4.15.0-151-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.16.5
  • go/linking: static
  • go/tags: none

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 18.04.4 LTS (GNU/Linux 4.15.0-151-generic x86_64)

Which cloud storage system are you using? (eg Google Drive)

pcloud

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

rclone authorize pcloud

A log from the command with the -vv flag

$ rclone -vv authorize pcloud
<7>DEBUG : rclone: Version "v1.56.0" starting with parameters ["rclone" "-vv" "authorize" "pcloud"]
<7>DEBUG : rclone: systemd logging support activated
<7>DEBUG : **temp-fs**: config in: state="", result=""
<7>DEBUG : Using config file from "/home/hd13/psfb/.config/rclone/rclone.conf"
<7>DEBUG : OAuth only is set - overriding return state
<7>DEBUG : **temp-fs**: config out: out=&{State:*oauth,,, Option:<nil> OAuth:<nil> Error: Result:}, err=<nil>
<7>DEBUG : **temp-fs**: config in: state="*oauth,,,", result=""
<7>DEBUG : **temp-fs**: config out: out=&{State:*oauth-confirm,,, Option:<nil> OAuth:<nil> Error: Result:}, err=<nil>
<7>DEBUG : **temp-fs**: config in: state="*oauth-confirm,,,", result=""
<7>DEBUG : Auto confirm is set, choosing default "true" for state "*oauth-islocal,,,", override by setting config paramete
<7>DEBUG : **temp-fs**: config out: out=&{State:*oauth-islocal,,, Option:<nil> OAuth:<nil> Error: Result:true}, err=<nil>
<7>DEBUG : **temp-fs**: config in: state="*oauth-islocal,,,", result="true"
<7>DEBUG : **temp-fs**: config out: out=&{State:*oauth-do,,, Option:<nil> OAuth:<nil> Error: Result:}, err=<nil>
<7>DEBUG : **temp-fs**: config in: state="*oauth-do,,,", result=""
<7>DEBUG : Starting auth server on 127.0.0.1:53682
<5>NOTICE: If your browser doesn't open automatically go to the following link: http://127.0.0.1:53682/auth?state=N9lsQUc0
<5>NOTICE: Log in and authorize rclone for access
<5>NOTICE: Waiting for code...
<7>DEBUG : Redirecting browser to: https://my.pcloud.com/oauth2/authorize?access_type=offline&client_id=DnONSzyJXpm&redire
2%2F&response_type=code&state=N9lsQUc0i3-LW9mDnei5Sg

hello and welcome to the forum,

if a token has been revoked, not sure what rclone can do about that.

hi thanks for the reply -

i am simply meaning i need to get the token again by reauthorizing (i have a working login to pcloud of course)

i am just re-running the authorize process again and it seems to fail.

thanks

try rclone config reconnect pcloud

rclone config reconnect
"Re-authenticates user with remote"

1 Like

Can confirm, as I'm having the same issue.

The problem seems to be that the OAuth app credentials for rclone have been revoked.

rclone authorize "pcloud"

doesn't work for that reason, and I am unable to generate a new token.

1 Like

hello and welcome to the forum,

try rclone config reconnect pcloud:

rclone config reconnect
"Re-authenticates user with remote"

1 Like

Thanks.

I appreciate the suggestion, but unfortunately that doesn't work, either. I've tried deleting the remote entirely (so "reconnect" doesn't apply), and again am unable to acquire a new token due to the aforementioned error.

1 Like

Has this just happened to you recently? I haven't been using my rclone with pcloud config in awhile, so I am wondering if the OAuth on their backend changed recently and caused this issue.

Maybe we should ask pcloud for support?

(also am I paid subscriber of pcloud)

$ rclone config reconnect pcloud
Error: backend doesn't support reconnect or authorize
Usage:
rclone config reconnect remote: [flags]

Flags:
-h, --help help for reconnect

Use "rclone [command] --help" for more information about a command.
Use "rclone help flags" for to see the global flags.
Use "rclone help backends" for a list of supported services.

2021/07/28 20:30:52 Fatal error: backend doesn't support reconnect or authorize

1 Like

pcloud, rclone thinks that is a local folder, thus the error.
non-local remotes needs a colon character :

try rclone config reconnect pcloud:

based on that error, i think you might be running an old version of rclone, latest stable is v1.56.0

It may be helpful to see if you can reproduce the problem.

  1. Remove all configured pcloud remotes.
  2. Try rclone config reconnect pcloud: . This will not work.
  3. Try rclone authorize "pcloud" . This will connect to pcloud and try to request an access token. It will fail with "Invalid 'client_id'".

I have tried this with stable (v1.56.0) and beta (v1.56.0-beta.5602.63a24255f).

1 Like

Can confirm it didn't error this time when I ran

rclone config reconnect pcloud:

as suggested, however, still unable to retrieve a token for my config with this command.

I deleted config and tried from scratch and can't proceed with getting authorized anymore

I believe pcloud OAuth has changed something with their backend and suddenly caused our sessions to expire

1 Like

if you remove all pcloud remotes, then there is nothing to re-connect with.
rclone config reconnect needs a remote in the config file but you removed all of them.
so for sure, the command will fail

i cannot see into your computer, and no point in trying to guess.
please post the exact command and output.
and post rclone listremotes

1 Like

i cannot see into your computer,
please post the exact command and output....
and post rclone listremotes

and i was able to run rclone config reconnect, worked no problem.

and after deleting the linked app from pcloud website, i was able to run
rclone authorize, without error.

1 Like

Yes, I realize it doesn't work. What we are describing is the act of trying to obtain new tokens, which is currently failing. The only way to simulate the acquisition of a new token is to delete your old ones.

But here is the output of the command to acquire new tokens:

$ rclone authorize "pcloud"
2021/07/28 12:50:12 NOTICE: If your browser doesn't open automatically go to the following link: http://127.0.0.1:53682/auth?state=che7wQooKPf9AjwV0GpGwQ
2021/07/28 12:50:12 NOTICE: Log in and authorize rclone for access
2021/07/28 12:50:12 NOTICE: Waiting for code...

Log an issue on the github and just link the article as and if you can, please post the link.

PCloud has done it before and I'm sure they'll do it again.

you can delete the linked app at pcloud website and then
rclone authorize pcloud

that worked for me

after deleting the linked app at pcloud.com website, i was able to rclone authorize pcloud
and i am able to rclone config reconnect multiple times in a row.

i think perhaps there can be only one linked app for rclone at pcloud.

Can confirm I've deleted linked devices/accounts in my settings.

Still not able to run rclone authorize pcloud and running into same error

Hello, the same problem started today for me also, I'm on Windows and pcloud revoked the authorisation, I tried to re-authorise it but pcloud gives the same error Invalid "client_id", I updated rclone to 1.56 but it's the same, in the pcloud settings there is nothing in linked apps, it got removed. THIS IS AN UGLY MESS!! It's probably too early to say but there is no communication about the rclone blockage from Pcloud, wanna bet Pcloud blocked rclone because it can encrypt files?

1 Like

We can't control what PCLoud does so please have one person open an issue, link it here and follow said issue.