Struggling to setup Dropbox app (API)

What is the problem you are having with rclone?

I'm not sure to understand how I am suppose to properly config / use the Dropbox API app :slight_smile:

Run the command 'rclone version' and share the full output of the command.

rclone v1.58.1

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.15.0-27-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.17.9
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount dbtv:/Chiffrement /test/ --vfs-cache-mode full

/Chiffrement being a team folder

The rclone config contents with secrets removed.

type = dropbox
client_id = censored, app key
client_secret = censored, app secret
token = {"access_token":"censored"}
shared_files = false
shared_folders = true
auth_url = http://localhost:53682/
token_url = SAME as access_token, idk if that's correct (I have tried both)

A log from the command with the -vv flag

Thanks you :slight_smile:

You have shared folder on but I'd imagine you didn't give the app permissions to list that as there are more steps for shared access.

This part:

You need to impersonate a user that hava access to the teamfolder in your dropbox business account as you are using a team wide token. There is a flag for that.
EDIT: This flag

Nope, that's properly setup :slight_smile:


How to use this flag ? Should I put my dropbox email (I tried but it's not working) ?

And after refreshing the token, I get this one :

Yet :

I can't actually read / make out your screenshots so I'm guessing something in there is the clue.

If you paste them as text, they are much easier to decipher rather than a blur to me.

2nd screenshot =
Failed to create file system for "dbtv:/Chiffrement": invalid dropbox team member: "xxx@xxx": Error in call to API function "team/members/get_info": Your app is not permitted to access this endpoint because it does not have the required scope ''. The owner of the app can enable the scope for the app using the Permissions tab on the App Console.

Edit : You can't click on them to zoom in ? It 's working on my side :grin:

Can you clarify what steps you've done? Are you using a team wide token?

Sorry as it's fuzzy / not searchable for other folks as I can list many more reasons why screenshots are not good.

If you put three backticks "`" those guys above and below text.

it looks like this

and keeps all the formatting.

Well, I created the remote (following this)

Then, since it was not working, I tried this command :
rclone config --dropbox-impersonate "xxx@xxx" reconnect dbtv:
(I also tried to modify my rclone config, since I wasn't sure what was tghe "token_url")

Which changed my token.

Are you trying to impersonate? The guide does not setup for that so you can't use impersonate unless you do something different.

I just created a new remote following the guide with no issues.

My app config looks like:

Keys are shown here as I deleted it anyway so doesn't matter:

Example rclone config:

Storage> dropbox
Option client_id.
OAuth Client Id.
Leave blank normally.
Enter a value. Press Enter to leave empty.
client_id> eijkhzdpaz7ps8z
Option client_secret.
OAuth Client Secret.
Leave blank normally.
Enter a value. Press Enter to leave empty.
client_secret> wl9zaeq3h4fn6ab
Edit advanced config?
y) Yes
n) No (default)
y/n> n
Use auto config?
 * Say Y if not sure
 * Say N if you are working on a remote or headless machine

y) Yes (default)
n) No
y/n> n
Option config_token.
For this to work, you will need rclone available on a machine that has
a web browser available.
For more help and alternate methods see:
Execute the following on the machine with the web browser (same rclone
version recommended):
	rclone authorize "dropbox" "eyJjbGllbnRfaWQiOiJlaWpraHpkcGF6N3BzOHoiLCJjbGllbnRfc2VjcmV0Ijoid2w5emFlcTNoNGZuNmFiIn0"
Then paste the result.
Enter a value.
type = dropbox
client_id = eijkhzdpaz7ps8z
client_secret = wl9zaeq3h4fn6ab
token = {"access_token":"sl.BHVQyYYwi0FezC2XT8TlYTPFeHA2uplocEDcI4Qo3VGhFAo6TrS0O2tX8Qy7t_1AdWjp-eW_MfGv17BxJdbNOuxvRXgi0lFl2J2VtaI8Pt8GPLUCSydo2svtIRtUTt6VRYhHPosl","token_type":"bearer","refresh_token":"ETl6N0z9g1AAAAAAAAAAAe_aFoo-eNC2014svV47Fh12k-cPmEDgp0GC6bPQkJJ1","expiry":"2022-05-10T12:34:40.69747-04:00"}
y) Yes this is OK (default)
e) Edit this remote
d) Delete this remote
y/e/d> y
Current remotes:

Name                 Type
====                 ====
DB                   dropbox
DBMovies             dropbox
DBTV                 dropbox
GD                   drive
TESTDB               dropbox
dcrypt-movies        crypt
dcrypt-tv            crypt
gcrypt               crypt
upload-movies        crypt
upload-tv            crypt

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config
e/n/d/r/c/s/q> q
felix@gemini:~$ rclone about TESTDB:
Total:   228.293 TiB
Used:    210.781 TiB
Free:    17.512 TiB
felix@gemini:~$ rclone lsd TESTDB:
          -1 2022-05-10 08:34:55        -1 SecureM
          -1 2022-05-10 08:34:55        -1 SecureT
          -1 2022-05-10 08:34:55        -1 Test

I'd like to config a remote with a team/shared folder :slight_smile:
In order to do that, I think I have to impersonate ?

No, I don't use impersonate nor the extra shared folder config.

I just add the shared folder to my dropbox and I can see it with a regular setup.

No extra stuff needed.

Amend your mount command with:

rclone mount dbtv:/Chiffrement /test/ --vfs-cache-mode full --dropbox-impersonate 

(where being a user on your dropbox team that has access to the relevant folder)

But for troubleshooting normally best to first test with a basic list command such as:

rclone -vv --dropbox-impersonate lsf dbtv:/Chiffrement

to make it simpler.

This config is working for me, but is it really going through the app ?

Also, what's the differences between rclone move and rsync ?
Is one better than another to move X To from Gdrive to Dropbox ? What if an error happens ?

Not sure what you mean? You mean using the client id and secret?

Rclone is the tool here and is a cloud based tool for interacting with cloud services.

Rsync is a file tool and not related to rclone.

You can't use rsync as it doesn't work with cloud remotes.

Yes, with client id and secret.

Well, ikr, but I meant rsync via the rclone mount VS rclone move ?

Drop App console logs requests and you can see after 24 hours. If it's there, it generally is working as if you it in the rclone.conf, that's really it.

I wouldn't even use a mount to move files as I'd go remote to remote. What would rsync do that rclone move would not? It's a separate program and another layer to have in the mix. I like less moving parts and the simple approach.

Within the "Analytics" ?

Well, I think I'll use rclone copy (I guess it's kind of the same as rclone move ?) :wink:

Yes, the part that says API calls per day.

It all depends on what you want to do.

Copy doesn't delete files from the source and move does.

Yes, that's what I wanna do :slight_smile:
I'm still using the GDrive with my Plex, so I'd like to copy everything before deleting the files.

Any idea how can I fix this error : Failed to copy: file name too long ?
Those files were not encrypted, and now that I'm trying to encrypt them, well...