Sonarr, Rclone, Plexdrive and UnionFS

Managed to Google 403 myself a couple of times using Rclone mount together with Sonarr.
So though I would check out UnionFS and plexdrive to circumvent that.
Does the following look okay?
/usr/bin/rclone mount --allow-other GoogleG3: /media/RcloneG3/
/usr/bin/plexdrive --fuse-options=allow_other,read_only --clear-chunk-age=120m0s /media/PlexdriveG3/
/usr/bin/unionfs-fuse -o allow_other,auto_cache /media/PlexdriveG3/=RO:/media/RcloneG3/=RW /media/Google

plexdrive = rclone mount (if it’s not rclone crypt decrypted content!)

I dont understand your message. I want to fuse Rclone and Plexdrive so it reads from plexdrive and write to rclone to prevent bans.

mount your GDRIVE with plexdrive

copy or move your files to GDRIVE with rclone (why would you need a 24/7 mount with rclone?)
do you have some HDD space local?
Like to store what you 've downloaded for 2-3 days? I guess you are not directly downloading to the rclone mount…
therefore that mount “is not needed”

I need a mount for Snoarr so it can manage/sort the files.

for me sonarr and radarr kills plexdrive not sure if it’s the amount of stuff etc so what I did was 3 setups.

Note I use encfs:
#local stuff
.local -> local

#rclone stuff
.rclone-encfs -> .rclone-decrypt
local (RW) + .rclone-decrypt (RO) -> cloud-rclone

#plexdrive stuff
.google -> google
local (RW) + google -> cloud

Point plex to plexdrive
point sonarr radarr etc to cloud-rclone

with this i am not even reaching or ocming close to my quota

aj1252, did you ever get this working? Does it work as you expected? I’ve been thinking of doing the same. I don’t really want a Local union like most people tend to have configured.

So I followed what you did and it makes sense. I had a work around in windows to do what you what you are doing. The only problem I run into is that Sonnar still sees that /Google folder as being a read-only folder. So basically, sonnar refuses to accept it. Any thoughts?

Never got it to work 100%. Due to the delays on the folder structure updates on Rclone and Plexdrive; both Sonarr and Radarr gave me tons of errors. Currently I’m using Amazon drive to handle the data and just mirror it to google.

On startup Sonnar writes a little test file on the root of your media path. Try mounting a empty local folder on Sonarr startup so it passes the test, then mount your real folders.

lol, ya on windows i was able to accomplish this but plexdrive is linux. i can run a vm and do xyz and share via smb… but don’t like. esxi has a limitations on hardware. On windows, I use the google file stream… then flexraid to create a storage pool… flexraid treated google file stream as a readonly drive and then my secondary drive… it would write data to. from that secondary drive, i used goodsync and it pushed data to my google drive. worked great… but windows lacks plexdrive lol. I have some genius linux co-workers and maybe they can look into. So how did the whole mounting empty folder and mounting real folders work out for you?

A tip is to also turn off “analyze video” in the advanced settings of raddar and sonnar. it really cuts down on the problems.

Not very well. Works for a bit, but as soon as you change the settings or it has some writing issues, it will redo the test and offline your path.

Another solution if you don’t mind syncing local files to the cloud is:

This will solve the write test issues, but there is some drawbacks.
New files will be placed locally if the folder do not exists in the cloud and need to be synced to the cloud.
The same applies to moving files they will be copied locally.

I’ll try that out and i’ll let you know what i come across. So are the local files still readable by plex… I’ll have to test this when back. Pushing to cloud will not be a problem. I’ll have to figure this part also. Coming from Windows has been quite a challenge, but getting there. I have a dual 2620 processor (12c/24thread) with 128gb of ram running pure ubuntu… so it’s quite powerful.

I tried this real quick, but assumed the above incorrectly:

sudo /usr/bin/unionfs-fuse -o cow,allow_other,auto_cache /home/gforce/sync/=RW:/home/gforce/plex/=RO:/home/gforce/rcloneg4/=RW /home/gforce/test4

showed that the file is still read-only, but i know it’s something I’m doing wrong. The mount test4 came up, but showed not writable.

Quick tested myself and its working as expected for me:
aj@HetznerSB79:~$ mkdir /tmp/TEST
aj@HetznerSB79:~$ mkdir /tmp/TEST/Local
aj@HetznerSB79:~$ mkdir /tmp/TEST/Plexdrive
aj@HetznerSB79:~$ mkdir /tmp/TEST/Rclone
aj@HetznerSB79:~$ mkdir /tmp/TEST/Fuse
aj@HetznerSB79:~$ chmod 444 /tmp/TEST/Plexdrive
aj@HetznerSB79:~$ /usr/bin/unionfs-fuse -o cow,allow_other,auto_cache
tmp/TEST/Local=RW:/tmp/TEST/Plexdrive=RO:/tmp/TEST/Rclone=RW /tmp/TEST/Fuse
aj@HetznerSB79:~$ touch /tmp/TEST/Fuse/TESTFILE
aj@HetznerSB79:~$ ls /tmp/TEST/Fuse
aj@HetznerSB79:~$ ls /tmp/TEST/Local
aj@HetznerSB79:~$ ls /tmp/TEST/Plexdrive
aj@HetznerSB79:~$ ls /tmp/TEST/Rclone

So I test it out. It works great and now the folder is writeable, but Sonarr and Radarr still treat it as though it’s not (the subfolders) it allows the main folder. So from what I gather is that I have to do that trick with the empty folder, dismount, mount this one so it will write to it. It’s awesome you got that piece solved.

You know what, there is flexraid for linux. If it works like windows does, problem solved.

UPDATE: looks like it’s working. will update more.

the mount works perfectly. sonnar is not rejecting, but taking it’s sweet time accepting it. will continue to check.

plex - your plex is big also. how much are you running space wise?

Damn it, makes it crashes. If it wasn’t for that, we would be set.

I’m at around 60tb at the moment. Try running it without cow and autocache. Cannot really remember but only got it working with a specific options.

Got everything working great. Using rclone and plex drive seperate, but sonnar and raddar work fine as long as analyze video are off.

The new limited version is great!

So what’s your end state? I saw that you said you had another 24 hour ban?