Sonarr, Rclone, PlexDrive and UnionFS expanded question

Sonarr, Rclone, Plexdrive and UnionFS

So long story short, I understand what aj1252 in SOURCE1 is trying to accomplish. I switched from windows to linux to run most of my stuff. The problem I’m having and that he is having is that Sonnar and Radarr kill the APIs with rclone (because the constantly scan). A solution to is read a drive for Plex is to use PlexDrive. PlexDrive is great, but it’s a read only folder. For Plex, awesome… because it reads the read only folder and never TRIPS the api’s for google. In order to write to a folder, we have to use rclone (and has to be read by Sonnar and Raddar). Sonnar and Radarr both require a writeable folder. So his idea was to do this

/usr/bin/rclone mount --allow-other GoogleG3: /media/RcloneG3/

/usr/bin/unionfs-fuse -o allow_other,auto_cache /media/PlexdriveG3/=RO:/media/RcloneG3/=RW /media/Google

and mine is

sudo /usr/bin/unionfs-fuse -o allow_other,auto_cache
/home/gforce/plex/=RO:/home/gforce/rcloneg4/=RW /home/gforce/google

So in the end, it does create a mount called google. The google folder has the same content from plexdrive and rclone… but the FOLDER google is NOT writeable. His idea was that google shows up… you point raddar and sonnar to the google folder… and then unionfs would push files to upload via rclone and that files read are coming from plexdrive.

Is there any way to have this google folder writeable? When it shows up, it shows that root is the owner… but even root cannot change the permissions of it or is there something missing in the commands?

Source 1

Source 2

The ownership of your /home/gforce/google folder is derived from the ownership of that directory before you tried to mount it. You simply can unmount hte unionfs, change the ownership to whomever you want, and remount the unionfs on it. My concern though is that unionfs is using the rclone mount as your RW volume. rclone doesn’t handle writing to mounts from tools like torrent clients because the torrent clients will allocate the file size in full and then fill in the bits. That will cause problems. Just depends on your use case of what you are writing to that folder which will in turn get uploaded via rclone.

1 Like

I tried changing the ownership before the mount and it didn’t work. Soon as it mounts, it loses whatever I gave it.

A solution I have now is: sudo /usr/bin/unionfs-fuse -o cow,allow_other,auto_cache /home/gforce/local=RW:/home/gforce/plex=RO:/home/gforce/rcloneg4=RW /home/gforce/fuse

Pushes to a local folder. The fuse folder is now writeable… but Sonnar and Radarr will not allow you to access subfolders to write to such as /gdrive/movies <<< movies will come up as not writeable but /gdrive/ will now

I am in the same boat trying to figure this out.