SFTP SSH Error - public key file is not a certificate file

What is the problem you are having with rclone?

So I am trying to setup a sftp mount and I seem to be missing sometimes, I am sure its something I did wrong, but looking through the docs, I don't know what it is. I can ssh /w pi@pi.hole without issue. I even created a new key without a keyword as I got a error /w a keyword. I tried /w my original ssh key, and tried creating a PEM version since thats what the rclone docs discuss is a PEM key.

ssh-keygen -t rsa -m PEM

What is your rclone version (output from rclone version)

rclone v1.54.0

  • os/arch: linux/amd64
  • go version: go1.15.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu server 20.04

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone ls rpi:

The rclone config contents with secrets removed.

type = sftp
host = pi.hole
user = pi
key_file = /home/dulanic/.ssh/id_rsa_rpi
pubkey_file = /home/dulanic/.ssh/id_rsa_rpi.pub

A log from the command with the -vv flag

2021/03/12 07:21:42 DEBUG : rclone: Version "v1.54.0" starting with parameters [                     "rclone" "ls" "rpi:" "-vv"]
2021/03/12 07:21:42 DEBUG : Using config file from "/home/dulanic/.config/rclone                     /rclone.conf"
2021/03/12 07:21:42 DEBUG : Creating backend with remote "rpi:"
2021/03/12 07:21:42 Failed to create file system for "rpi:": public key file is                      not a certificate file: /home/dulanic/.ssh/id_rsa_rpi.pub

I don't think you want to use this - it is for using with signed certificated.

Just remove this line.

If your key_file has a password you'll need to specify it - run through the config again and it will ask you for it.

Hopefully that will fix it.

I agree that it is a little confusing and I can see why you did what you did.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.