Root_folder_id & Token not getting auto generated

What is the problem you are having with rclone?

i came accross rclone very recently i am trying lot of things inlcluding creating many remotes and deleting them .i always tend to skip the rclone config screen where it asks to enter root_folder_id so that it may set it automatically once i give rclone access of my google drive ..But the issue is while creating remote , randomly it will skip asking for rclone permission at end and doesnt redirect to browser to give gdrive access to rclone .As a result ,the root folder id and token is absent from my rclone.conf . This doesnt happen all the time but its random and quite annoying as i dont really know in which further attempt it will work properly again

What is your rclone version (output from rclone version)

rclone v1.51.0

Which OS you are using and how many bits (eg Windows 7, 64 bit)

  • os/arch: windows/amd64
  • go version: go1.13.7

Which cloud storage system are you using? (eg Google Drive)

Google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

<The issue happens at remote creation phase itself explained already>

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

Can you make a reproduction for me so I can see this going wrong here?

Are you doing lots of configs at the same time? That could cause the problem.

yes i have created and deleted many configs ,can say that and this issue is random like for some attempts it wont ask for permission and maybe next time it does

here i have attached a pic , hopefully it may help
As you can see , it never redirected me to browser for permissions and ended the config screen without token and root_folder_id

I was wondering if there's a way to manually trigger the rclone google authorisation at the very end in case the automation fails for some reason

  1. I dont think service_account_file_path is a valid option for rclone drive

  2. Also if you use service account and not configure it as a team drive you'll only have the config like below

type = drive
scope = drive
service_account_file = /path/to/serivce/account/1.json

but after running a command using the remote once it'll add the root_folder_id to config (ex: rclone lsd test:)

type = drive
scope = drive
service_account_file = /path/to/serivce/account/1.json
root_folder_id = xxxxx
1 Like

i understood your second point and my config looks like the one you have posted as sample. i realize there is nothing wrong now. i was using service account file and not configuring it as team drive hence it didnt needed token .Sorry for posting i didnt knew how it works as i am using rclone since yesterday only.

Yes you can use rclone config reconnect remote:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.