Restore help - mistakes were made!

Dear fellow rclone users...

merry christmas to everyone :slight_smile:

I need help to restore my rclone-encrypted remote files.

Background: I messed up my freenas server. I've stored all my important pdf documents (8GB!) there and did set up a remote backup ("freenas cloud sync task") which is based on rclone to backblaze b2. Solid idea.

Tl,dr: I tampered with my server, all data gone, the only data that is left is the remote backup at backblaze, rclone encrypted.

Sooo, how do i decrypt the remote backup? I have the encryption password and the salt.

What i tired:

Set up the b2 remote on my Windows 10 machine. Okay, access works.
Set up a b2_crypt remote with the same password and same salt that i used on freenas --> lists no files.

rclone cryptcheck b2:bucket/dir b2_crypt:bucket/dir gives:

ERROR : on0gsdebepnv1t388ii5gtac5c/cbec70atk70pelocp4b7mivchk/7ogh466ih774gga09cbeg1mm4g: File not in Encrypted drive 'b2_crypt:bucket/dir'

So it seems that rclone is not recognizing the already existing encrypted files.
I thought about just downloading the bucket from b2 and to a manual by file decryption...but i can't find a way to do this...

Edit: Here is my rclone conf:

type = b2
account = ID
key = KEY

type = crypt
remote = b2:backup-nas
filename_encryption = standard
directory_name_encryption = true
password = PASSWORD
password2 = SALT

What am i doing wrong? Any help is appreciated to restore my files. Thank you very much!

Getting this working is the first step.

I think you might have been erroneously including the bucket - you don't need it as it is in the crypt remote setup. Try this, does it list your files? If not paste the messages.

rclone ls -vv b2_crypt:

I have probably the same problem. Only thing I lost was the rclone.conf, so I created a new one with same settings. When I tried to paste the password (client is in Windows Server), it seemed to think I entered no password so I entered both passwords manually and tried it several times.

It either won't list any files, or tries to list some in subfolders that are non encrypted folder names but shows non-printable characters and sometimes beeps while listing.

I am wondering if the password was entered wrong, assuming it should be possible. I tried generating a new password and it can store new files but can't read the old ones.

ncw & imjaeff, thank you for your replies.

ncw, if i use

rclone ls -vv b2_crypt:

i get:

C:\Users[USER]\Software\rclone>rclone ls -vv b2_crypt:
2019/12/27 00:09:33 DEBUG : rclone: Version "v1.50.2" starting with parameters ["rclone" "ls" "-vv" "b2_crypt:"]
2019/12/27 00:09:33 DEBUG : Using config file from "C:\Users\[USER]\.config\rclone\rclone.conf"
2019/12/27 00:09:36 DEBUG : config: Skipping undecryptable file name: illegal base32 data at input byte 6
2019/12/27 00:06:44 DEBUG : [user]/bkne32vltslo8cqfhut4tpqmh8/250d3tatsgah7sl7gprlrhg9028qnh1hfer2dhdkd6c94bhjf31eu97a7fkggk7quqpfemt9tj5vu/2p2r5n1a12g3j8isf2gjmh2ejg/0lpo6slojh8jdcvgh75hr9qct4/i9ohev0dvjccb9qnrobmm0tlsflnrlm75nhpkahe7au0imb88j6uuvdd1ia6hnrvdrvfb168s57mq: Skipping undecryptable file name: illegal base32 data at input byte 5

So it seems as if either the filename encryption used by rclone on freenas is different or that something else is wrong (maybe the passwords? but i am certain that they are the correct ones, i generated them with 1password and they are stored there...)

Edit: I've tried

rclone ls -vv b2_crypt:scanner

because the b2 bucket looks like this: nas-backup/scanner

it gives me only this:

2019/12/27 00:24:24 DEBUG : rclone: Version "v1.50.2" starting with parameters ["rclone" "ls" "-vv" "b2_crypt:scanner"]
2019/12/27 00:24:24 DEBUG : Using config file from "C:\Users\[USER]\.config\rclone\rclone.conf"
2019/12/27 00:24:27 DEBUG : 7 go routines active
2019/12/27 00:24:27 DEBUG : rclone: Version "v1.50.2" finishing with parameters ["rclone" "ls" "-vv" "b2_crypt:scanner"]

And nothing else, no files listed.

So far I have confirmed that it is possible to paste the passwords on another computer, but I haven't tried it from 'nix to windows, they were both windows. I doubt that is a problem though, it is just so hard to make sure you typed the password correctly. When I set up my Windows Server to do the backups with same passwords that my win7 used rclone to generate 128-bits of password, I may have typed it in wrong back then so now typing it correct is incorrect.

Here is my output that shows similar problem as yours, when it decrypts the filename it is I guess invalid data for the buffer. [sorry if I can't figure out how to do formatting]

rclone -vv ls eadrive:cad
2019/12/26 17:04:14 DEBUG : rclone: Version "v1.50.0" starting with parameters [
"rclone" "-vv" "ls" "eadrive:cad"]
2019/12/26 17:04:14 DEBUG : Using config file from "C:\\Users\\[user]\\.config\
2019/12/26 17:04:16 DEBUG : 
oon7jc5jubmoeuknblojubs46: Skipping undecryptable file name: Bad PKCS#7 
- too long
2019/12/26 17:04:16 DEBUG : 7 go routines active
2019/12/26 17:04:16 DEBUG : rclone: Version "v1.50.0" finishing with parameters
["rclone" "-vv" "ls" "eadrive:cad"]

If it can't decrypt as that error shows, that means the password and/or salt are wrong.

I find it is better to keep a backup of rclone.conf and not just the passwords, because it is easier to tell on the hash if the password was different. I could not get access to that file on the previous installation because it said it was right there in users[name].config\rclone\rclone.conf yet in a dos window there was no way to see such file, it didn't exist. I tried dir /a and attrib.