[resolved] Failed to save config file

I am running rclone 1.36 under Ubuntu 17.10 Beta2, but I am not able to create a new config. Every attempt failed with the error message

Failed to save config file: open /home/xxxx/.rclone.conf: permission denied

With the same level of permission, I can run touch .rclone.conf and the file is correctly created under the same location.

I’ve also tried to run with root permission (sudo), but it also failed with same error message.

Any idea?

Check the ownership of the .rclone.conf file - make sure it is owned by the user not root.

The file does not exist, it is a fresh new installation.

You have mentioned that when you touch .rclone.conf the file is correctly created. Who is the owner of .rclone.conf after it was created and what are the permissions?

Current user is the owner the file with following permissions -rw-r--r--. So nothing weird on this side.
But note that it is point less to create the file this way since rclone cannot open the file, and it stops before displaying the configuration options.

Just tested with the latest release 1.38 and it works fine.

There were some config file handling fixes between 1.36 and 1.38. Is your home directory on a different file system to your /tmp directory by any chance?

Nope. This is standard Ubuntu installation. User’s home directory is under /home and on the same fs as /tmp.

Hmm, OK! Well I’m pleased that 1.38 fixed it!

Same issue. To make it work i had to use
snap install --classic rclone

1 Like

I'm trying to use rclone on a Snap installation with Nextcloud (Ubuntu 18 on a remote VPS). I get the same "Failed to save config..." error.

I've installed rclone via Snap which seems quite old now (1.36) - where do you get 1.38 from? Also I tried installing it from the installation script here:

https://rclone.org/install/

which installs v1.55 (I think) but the config wizard script has totally changed and fails trying to get the authorization token from Dropbox (with 1.36 you can paste the prompt URL into a browser but 1.55 URL is using a local URL (127.0.0.1) which doesn't work as I'm on a headerless remote VPS.

Any help greatly appreciated!

Neil

Just managed to get the config script to run by installing rclone with the --devmode option (--classic is ignored in Snap due to Snap's security protocol).

I'm now getting an error which seems to be to do with rclone using old (outdated) autorization API:

rclone ls remote:
(produces the error): "Failed to ls: couldn't list: v1_retired"

Please create a new post and use the question format to include all the right information.