Failed to save config file


Upon fresh install and first attempt to add a remote, I get this:

2020/04/11 17:48:29 Failed to save config after 10 tries: Failed to create temp file for new config: open /.../.../.config/rclone/rclone.conf649949317: permission denied

The directory .config/rclone has permissions (0755/drwxr-xr-x).

Very literally the same bug as here, except with version:

rclone v1.51.0
- os/arch: linux/amd64
- go version: go1.13.7

What do you recommend I do?
Thanks very much in advance!

hello and welcome to the forum,

not sure we can call this a bug yet.
it seems to be a permissions issue that could happend with any app.

how did you install rclone?

Hi, thanks !

Well, I simply followed the instructions on the install page:

curl | sudo bash

I'm surprised as I installed rclone (probably the same way, can't remember) on another machine with Linux Mint a year ago or so and everything went smoothly.

What user are you running as?
What does:

rclone config file


from that same webpage

sudo cp rclone /usr/bin/
sudo chown root:root /usr/bin/rclone
sudo chmod 755 /usr/bin/rclone

Just the local user, no sudo. I tried now with sudo rclone, and that works, but I was hoping to be able to use it and configure it only as a local user.
The result of rclone config file is


However, the dir is empty.

This is a bug in the install script which accidentally leaves your config directory owned by root :frowning:

sudo chown -R $USER ~/.config/rclone

should fix it

1 Like

Well, I thought that part of the install was only required if one wanted to download specific binaries or versions separately. The script already installs rclone to /usr/bin/ and the authorizations are already 755.

Awesome @ncw, worked like a charm, thanks!

1 Like

And grand software, very helpful !!

1 Like

I fixed the now :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.