Rcx rclone android question

What is the problem you are having with rclone?

Hi, I have a general question as I just don't understand the result... I honestly don't know much about the whole thing and I'm probably just doing something fundamentally wrong....

I installed RCX rclone for Android and created a crypt remote with the name test. As a password I have also assigned test. After that, I just put in a text file

If I now open this directory directly in pcloud and open the file, then I cannot access it. So far so good!

Now I deleted the crypt remote via rcx app and created a new crypt remote with the name hello and password hello. The remote refers to the same pcloud directory as the previous test remote.

I would have expected that I would NOT be able to open the previously recorded file anymore... But I can open the file.

I exported the config file and there is no entry for the deleted test crypt remote. Why can I still open the file? I just don't understand that...

I hope I have expressed this in a reasonably understandable way. Thank you very much!

Run the command 'rclone version' and share the full output of the command.

I only have the android Version and I use pcloud.

hello and welcome to the forum,

that is how it works,
if you create a new crypt remote with the same values including password as the deleted remote.
then you access the files.

these two remotes are equivalent.
rclone ls remote01: will output the same as rclone ls remote02:

type = crypt
remote = remote:folder
password = BNTJkTcj_9LLJJmlrehX6I7vwTds8NFr
password2 = jFhc0X1-bPsAS0I7EL1VDONyn3E88_1y
type = crypt
remote = remote:folder
password = BNTJkTcj_9LLJJmlrehX6I7vwTds8NFr
password2 = jFhc0X1-bPsAS0I7EL1VDONyn3E88_1y

Thank you for your quick reply. I understand that, but that's exactly what I didn't do.

I deleted the old crypt remote and created a new one with different values. But I was still able to open the file?

sorry, i mistunderstood.

that is not possible.

the odds are the text file was never crypted.
and should be very easy to test.

best to post the answers to the help and support template questions

Unfortunately I don't have a PC at hand but I try to show it in pictures :

Create a new crypt remote test. Password is test.

Upload file hallo.txt

File can be opened via rcx app but not in pcloud:


Now I delete the crypt test and create a new crypt Hello with hello as password. This points to the same pcloud directory and I can open the previous file. No idea what I'm doing wrong. Everything as I said only with the android app.

New config

The [test] Entry no longer exists in the config.

so you do not have access to a desktop computer to test on?

just wanted to point out that rclone itself runs fine on android, no need for rcx.

What would it use to test this on a PC? I want to do it on Android and it doesn't work there. I know that it works without the app but it should also work with the app and the app should make it easier, right?

Most likely you copied the file to the regular remote rather than the crypt remote.

You didn't use the template so have no idea.
You didn't share the commands you ran to copy the file.

If you have different passwords, you get an error when you try to open the file.

If you want to share the commands you ran and how tested it, we can find the process error you have.

That's really why we have the template so it's not just a guessing game on what happens but you ignored that and we're down a series of question for basic functionality in rclone.

well, this is a forum for rclone, not rcx, tho we do try to help.

rclone can run on android using termux, makes it easier to debug.

I have not posted any commands as I have not used any. I have only used the internal functions of the app and with this I can not send commands. As I understand it, this is all done automatically in the background.
That this is not a guessing game is clear to me and that's why I tried to show as well as possible what I did in the app. I did not want to ignore anything here. I just can't deliver it according to my understanding....
But okay I understood that they probably can't help me with the app here.
If my questioning has come across as stupid then I'm sorry. That was not my intention.
Thanks anyway for your time.

It is guessing as we don't know how you copied the files to your remote.

You have file encryption off and it's a pretty easy conclusion / guess to assume you copied to the non encrypted remote via the app or the app is broken (seems unlikely but who knows).

I uploaded the file in the app with the upload function of the app.
I did not insert the file directly in pcloud or something like that.

How? Which remote did you pick? Screenshot if you can't post commands. Something as we can keep guessing on the process you used or you can share specific steps with screenshots if it an app.

I picked the crypt remote:

for testing, remove these from the remotes.

rcx has a log file, might help with debugging.

I think I have it now...
So far I have always created a crypt remote and then opened the file testwise in the crypt remote. This has worked so far.
Then I deleted the crypt remote.
After that I created a new crypt remote and set a different password but pointed to the same pcloud directory (with the already encrypted file which can not be open in pcloud). Despite the different password I could still open the file in the rcx app.
Now I deleted the cache of the app after creating the new crypt remote. In this cache the file hello.txt was explicitly present.
After I deleted the cache I can only open the file with the correct password.

Can this be / does this make sense?

not sure what that is, what cache, where is it located?


rcx uses an old, custom compiled version of rclone.
perhaps post an issue at rcx github.