RClone Synology install script help

Apologies in advance for splitting my question up into multiple replies. I spent 45 minutes battling with the 'new users cannot post more than two links' limitation, desperately trying to ferret out anything it deems as a 'link'!

What is the problem you are having with rclone?

I am new to rclone. I've followed the guide here to set it up to mount my Google Workspace drive on my Synology but it's failing right at the very end with the error
2021/04/07 11:35:35 NOTICE: Config file "/var/services/homes/acmadmin/.rclone.conf" not found - using defaults

2021/04/07 11:35:35 Failed to create file system for "gdrive:": didn't find section in config file

What is your rclone version (output from rclone version)

rclone v1.55.0
- os/type: linux
- os/arch: amd64
- go/version: go1.16.2
- go/linking: static
- go/tags: cmount

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Synology DS918+
DSM 6.2.4-25556

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsd gdrive:

The rclone config contents with secrets removed.

hello and welcome to the forum,

this is not a rclone issue but a linux file permissions issue.
you ran rclone config using sudo, but ran `rclone lsd gdrive: without sudo.

rclone cannot find/access the config file.

Aha. Thank you.

I can now see the drive contents using the rclone lsd command.
Can you point me in the right direction to mount gdrive on my Synology filesystem so I can read/write to it in DSM and from other DSM apps/containers?

this would be a basic command to test.

rclone mount gdrive: /path/to/local/folder --allow-other

Forgive my ignorance with the syntax.
sudo rclone mount gdrive: /gdrive —-allow-other —-daemon

Is returning
Command mount needs 2 arguments maximum: you provided 4 non flag arguments: ["gdrive:" "/gdrive" "—-allow-other" "—-daemon"]

this worked for me
rclone mount remote: /volume1/homes/user99/rclone/mount/remote --allow-other

i can see the files in the DSM file manager.

I tried creating a new folder called gdrive as a DSM shared folder, so it appears in DSM File Manager (under /volume1).
But still the command is failing for me. Here's the full output.

you need to post the command

It's on line 1 of the pastebin, but here it is again:
sudo rclone mount gdrive: /volume1/gdrive —-allow-other

here is what i did,

  1. created a shared folder named remote
  2. created a sub folder under remote named mount
  3. ran this command rclone mount remote: /volume1/remote/mount --allow-other
  4. on my windows computer, net use j: \\bnas.local\remote
  5. open vlc, point to j: and watch a video

This is what I have done:

  1. Created a shared folder called gdrive
  2. Ran the command sudo rclone mount gdrive: /volume1/gdrive —-allow-other
  3. Get the error:
    Command mount needs 2 arguments maximum: you provided 3 non flag arguments: ["gdrive:" "/volume1/gdrive" "—-allow-other"]

This is where I am stuck :frowning:

try --allow-other

Did you mean 'try removing' --allow-other ?

So I tried that, and it worked. It successfully mounted to the gdrive folder and I can browse it in Synology DSM. So the problem is the flag error... any ideas on fixing that?

your —-allow-other does not look valid, so replace it with --allow-other

but if your command is working without it, no need to use it.

I don't understand what you mean

compare your text —-allow-other with my text --allow-other, they are not the same
your text is not syntactically correct and that is why rclone is complaining