Rclone rc operations/list not listing files on a mapped Windows network drive

What is the problem you are having with rclone?

Hi all. I'm unable to use the rc operations/list command to list out the contents of a network drive mapped to a letter. I can use the rc command to list the files on the local C: drive but I can't seem to use it to list on the letter mapped network drives. I've previously used this syntax before successfully for a second drive (a D: drive), however that was a second local drive and not a mapped network drive.

Can anyone advise? Is it the fact it's a mapped network drive causing this issue? is it perhaps authentication? (Shouldn't be as I authenticated already when mapping?)

What is your rclone version (output from rclone version)

rclone v.148.0

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows Server 64bit 2012

Which cloud storage system are you using? (eg Google Drive)

Mapped network drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone rc operations/list fs='localdisk:y:' remote= --rc-addr=https://USER:PASS@ADDRESS:PORT --no-check-certificate --timeout=0

The rclone config contents with secrets removed.

rclone rc --json '{"name":"localdisk","type":"local","parameters":{}}' config/create --rc-addr=https://USER:PASS@ADDRESS:PORT --no-check-certificate --timeout=0

A log from the command with the -vv flag

DEBUG : rclone: Version "v1.48.0" starting with parameters ["rclone" "rc" "operations/list" "fs=localdisk:y:" "remote=" "--rc-addr=https://USER:PASS@ADDRESS:PORT" "--no-check-certificate" "--timeout=0" "-vv"]
2020/11/23 22:36:48 Failed to rc: Failed to read rc response: 404 Not Found: {
	"error": "error in ListJSON: directory not found",
	"input": {
		"fs": "localdisk:y:",
		"remote": ""
	"path": "operations/list",
	"status": 404

that version is approx 18 months old.
perhaps download the latest and test again.

how did you map the network drive, via command line, windows explorer or what?
windows keeps two lists of mapped drives,
one list for a user running with admin rights
one list for a user running without admin rights.

what happens if you try rclone ls y:

as a test, try to run rclone rc as system user?

can you give an example of this using the c:

Sorry just to clear up if I run

rclone ls y:

locally it works and lists the drive

I mapped using windows explorer, just the option there

I've re-run the rc command as an admin (think I did so first time but I've just retried in case) and that doesn't work.

what rc command are you using that work with c:, but not the mapped drive.

This command

rclone rc operations/list fs='localdisk:' remote= --rc-addr=https://USER:PASS@ADDR:PORT --no-check-certificate --timeout=0 -vv

Previously the syntax 'localdisk:D:' had worked (in another server) for the D drive. But that was another local D drive.

for a remote

type = local

this worked
rclone.exe rc operations/list fs="local:v:" remote=""

1 Like

Sorry I don't quite understand
I've used this command to set up a config file for the rc command

rclone rc --json '{"name":"localdisk","type":"local","parameters":{}}' config/create --rc-addr=https://USER:PASS@ADDRESS:PORT --no-check-certificate --timeout=0

which I can use to list the local C drive but not the mapped network Y drive

I then created a local config to test if I can map the Y drive and I can use that to list both. (I had to create a second config as I think the local ones and the rc ones are different no?) Or at least when I list the configs locally they don't show the RC configs I've created. And yes the type of both remotes is local.

not an expert at json but when i run your command

rclone.exe rc --json '{"name":"localdisk","type":"local","parameters":{}}' config/create --rc-addr= --no-check-certificate --timeout=0 
2020/11/23 19:03:56 Failed to rc: bad --json input: invalid character '\'' looking for beginning of value

Ah maybe try this? Both formats work for me

rclone rc config/create --json '{"name":"localdisk","type":"local","parameters":{}}' --rc-addr=STRING --no-check-certificate --timeout=0

both commands are the same.
and both give me that same exact error.

are you still running v.1.48.0?

Hi I was, just tried to update to the latest one. Still doesn't work. That's strange, the only \ I'm seeing is the \ in config\create which is correct according to https://rclone.org/rc/

What command would you use to create a local disk config using the rc config/create command?

i never used config/create before.

to be clear, are you getting the same error i am or some other error?

No error at all! works fine for me

what version of rclone are you running?

Ah crap there's the local version I'm using as well to send out the RC command which is still 1.48.0

I only updated the one running on the remote machine to the latest one, would that matter?

i would not know as i always use the same versions.

strange, on wsl2 your command runs without error

Oh this is new, the rclone I updated to the latest version on the remote machine no longer lists the mapped network drive using this command
rclone ls y:

on linux via wsl2

user01@EN07:/mnt/c/windows/system32$ rclone rc --json '{"name":"localdisk","type":"local","parameters":{}}' config/create
user01@EN07:/mnt/c/windows/system32$ rclone listremotes
user01@EN07:/mnt/c/windows/system32$ rclone lsd localdisk:/mnt/c/ex/bit
          -1 2020-07-11 19:49:52        -1 savepath
          -1 2020-07-11 19:49:52        -1 torrentfilefinished
          -1 2020-07-11 19:45:22        -1 torrentfiles

are you running the command with or without admin rights?

Been doing it with admin rights