Rclone mount random slow speeds

Hey Man, I'm in Canada! And have the same issue. Some days my plex managed users can stream UHD Remux, others day not a chance.

Ok so this either because you began this test with a already modified hosts file with all those IPs. Or its because your hosts file isn't being overwritten from backup. I'm guessing that's because you used a incorrect password for sudo permissions (all hosts file related commands require sudo) and the script just simply carried on. But there might be another reason that will need a little searching for you.

I'd recommend clearing out those IPs manually from your hosts file "sudo nano /etc/hosts", and then delete the hosts backup that it's got to start fresh "sudo rm /etc/hosts.backup". Then give it another shot starting from this fresh begining.

To explain whats happening in the script a bit more:

-It firsts checks if you have a hosts.backup file, if not it creates one. If yes it restores from the backup to reset your hosts file back to what the backup has.

-Then during the IP checking, it adds a single line to the hosts file. Does the download. Then restores your hosts.backup file, overwriting it back to fresh, loops back around and tries the next IP. During this time, it's assuming there's only a single IP in the hosts file, if you have more then it would appear to be lying to you by checking the wrong IP.

-It repeats until done, it then restores the backup one last time, then does the logic for finding the fastest IP, and edits your hosts file one more time with the fastest one.

Again sorry, my script has 0 error detection and assumes everything will work perfectly. So in turn we have to act perfectly with it, with a perfect starting hosts file and a perfect password entry.

1 Like

I ran the script as detailed above. On my 1gbps up/down connection I am seeing 72 MiB/s as the max and it seems the rclone mount is now stable and working as previousily. Quick question, since I am in Canada, are there specific google IP's for me? My understanding is that they have datacenters in Edmonton Alberta :slight_smile:

Right, I think it's now working correctly. One single IP in hosts file at any given time during script running. One at the end, the fastest measured.

It all appears to be working just fine. There's no need to flush DNS as, I tested this, hosts file content takes precedence. As soon as I change the IP in hosts file a ping to www.googleapis.com goes to that IP.

I still suggest anyone capable of translating the script to a Windows batch file to do so. The hurdles to overcome to have it run under WSL are... tedious, let's say.

EDIT:

One thing you might wanna check out in your script: if more than one IP gives the same result, all are inserted in the hosts file but only one with correct syntax, like this:

142.251.209.42
216.58.212.170
142.250.184.42
142.250.180.170	www.googleapis.com

I don't think it creates an error in use but it might be problematic for following runs of the script, maybe? Maybe not, since hosts.backup should be an empty file and it's restored before testing... well, I thought it was worth to point this out anyway.

Hi guys,

I have a similar issue (downloaded approx 50tb in a few weeks without any issue, then a few days ago, it started at full speed, then dropped to under a kilobyte per second speeds!!!)

I run rclone on my unraid server at home. Do anyone here have a script I could try to use to fix this ? I'm located in EU -> Belgium.

I've seen an improvement over the past few days in the US.

All endpoints consistently reporting full speeds.

1 Like

That's great. I'm currently on vacation, so I haven't been able to do any further testing.

Yep. Both of our scripts do a little check for what IPs Google gives out in your region and checks those ones. Your list of IPs will be different from mine in Aus. In this thread someone posted a bunch of IPs from around the world, feel free to add some extra ones from other countries in the whitelist file while using my script.

Heh funny bug. The way my script works is by saving each IP in it's own file called the speed, ie "82.11". Then when it's done, it sorts them and finds the highest number. Then the IP in that highest number file is what it puts into the hosts file.

I've never encountered the same speed more than once in my tests and havent accounted for it at all. Again its a shitty script with no error detection at all and just expects everything to run perfectly. Definately needs to be babied a bit.

Same! I just ran mine again without a blacklist file so it checks them all and there were no bad IPs. Maybe they finally fixed the issue and like someone mentioned above, the new config gets slowly rolled out to the different regions.

Out of eight IPs today only one is slow. Which makes the manual configuration still necessary.

And today all IPs for my country/region are fast as they used to be. I'll monitor on a daily basis for a while...

I wish to thank @Nebarik for the script and all the help he provided in making it work for my "special" case (WSL under Windows).

It turns out that some of the script variables don't like absolute paths. Once I got that sorted out, everything is working.

check the DEFAULT_ variables for reference

I've observed the same change in south america. do not think the scripts are necessary anymore but I'll keep running just in case.

All my endpoints in australia are back to permanent full speed as well, including the IP that always slow. Seems google have fixed their F UP.

I have unlimited download on my host machine, so I'll continue to run the script just in case.

Big thank you to those who put together and shared their scripts. Much appreciated.

The issue is still ongoing in South Africa. All the South African endpoints are giving around ~200Mbps some even lower at 15Mbps or so.

There is a server in Kenya mba01s09-in-f10.1e100.net which is only ~50ms from Johannesburg that is pretty fast and I can max my 1Gbps connection by just using the --drive-chunk-size 256M flag.

2a00:1450:401a:800::200a
172.217.170.170

2 Likes

Tonight, for a short while, I was back at 20Mbps. I ran the script and all IPs for my zone were fast... but it happened, I checked it while it was happening and the slow speed was there for a couple of minutes.

Just when I thought that this was solved for good. :confused:

Also seem to be having 20mbps stints tonight. had the script only running once a day, but seems like i need to move back to more regular intervals again : (

Been haveing a issue tonight thought to check this thread if any one else haveing a issue

Tried yesterday. All IPs were fast from my location. One thing I've noticed is that, instead of the usual 8 IPs I was pinging till mid August now there are 14 of them available.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.