Rclone mount + plex help

What is the problem you are having with rclone?

I am trying to mount my gcache to be used by Plex, however im not sure if mounting is correct as plex will not read anything from the library.

What is your rclone version (output from rclone version)

rclone v1.52.0

  • os/arch: linux/amd64
  • go version: go1.14.3

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount gcache: ~/mnt/gdrive 

The rclone config contents with secrets removed.

type = drive
client_id = HIDDEN
client_secret = HIDDEN
scope = drive
token = {"access_token":"ya29.a0AfH6SMA9St1AYkJbYqS2A-y0O5JAxFbqLHn66y3CbtACYp7zUdxuVuhMn8CizcdNEm5S7n4SD2ogopk1wdV1RQcHlbvRVOJkrqRghjhtkWAIbvSRIjsS0GYJstuaf7_iU4UFTn5GjvnPYDLIAJrVJnhXdFFozllG-0dT","token_type":"Bearer","refresh_token":"1//09sgwoGM1usi_CgYIARAAGAkSNwF-L9IrOdcFCzMEeVuMdX9DcNmChAxDTGarAoxQqcfYb2SQYUgEIE5AkNlBfgOeGjJ07JHVQns","expiry":"2020-06-10T16:55:52.316060504+02:00"}
root_folder_id = 0AItUOn0nYsDvUk9PVA

type = cache
remote = gdrive:/Movies
plex_url = http://gold.seedhost.eu:30623/web
plex_username = dank@wegotboof.me
plex_password = ENCRYPTED
chunk_size = 32M
info_age = 2d
chunk_total_size = 20G

A log from the command with the -vv flag


From what I understand my cache is working as I can use command

rclone ls gcache:/

this correctly shows me all the files in my Google Drive in the Movies folder that I want in Plex. Any advice here?

You need to use --allow-other for a user different than the user mounting it to see files.

I'd probably not use the cache backend either as it isn't needed 99% of the time.

Thats what I thought might be the problem, however I cannot edit fuse.conf due to permissions. I asked seedhost support and they said:

You can't use --allow-other so you need to remove it from your command.

Best Regards,
SeedHost.eu Support Team

I am the only user on Plex account if that makes any difference.

Are Plex and rclone running as the same user?

Im sorry I have low lvl understanding of ssh so im learning as I go. I dont know how to find out that info.

Are you using a shared seedbox or a dedicated one? That would probably point us in the right direction.

Shared seedbox. Before I got it I emailed support and asked if mounting was allowed since fuse doesnt work on feralhosting they told me:

"Yes you can use rclone and mount with fuse as well."

So yep, on a shared seedbox, you cannot use allow-other and I'd strongly guess they are running as the same user.

What happens when you:

ls ~/mnt/gdrive 

Do you see files?

I was able to mount the gdrive remote instead of the cache remote with

rclone mount -vvv --allow-non-empty gdrive: /home14/dank/mnt/gdrive

When i add the & parameter I can then use

ls ~/mnt/gdrive 

and it shows me the files. Plex is still not seeing them.

Non empty is bad. You want to mount to an empty directory. You should remove that and remount clean.

Ok making some progress

rclone mount gdrive: ~/mnt/gdrive --daemon

ls ~/mnt/gdrive

Shows me my files. Still cant get them in plex tried adding library folders




plex still doesnt see any files

1 more thing when I try to add the plex library in the /dank/mnt/ directory instead of showing gdrive as a directory it shows it as 1 unselectable file. here is a screenshot https://imgur.com/a/orAWFXw

You are a bit ahead of me.

If you run:

ls -al /home14/dank/mnt/gdrive

What's the output?

Also, what does:

ps -ef | grep plex


the first command gives me:

drwxrwxr-x 1 dank dank 0 Jun 4 16:15 Anime
drwxrwxr-x 1 dank dank 0 Jun 4 21:25 Books
drwxrwxr-x 1 dank dank 0 Jun 4 22:03 Education
drwxrwxr-x 1 dank dank 0 Jun 4 21:29 Graphic Novels
drwxrwxr-x 1 dank dank 0 Jun 4 22:18 Howard Stern
drwxrwxr-x 1 dank dank 0 Jun 5 18:16 Misc
drwxrwxr-x 1 dank dank 0 Jun 4 16:09 Movies
drwxrwxr-x 1 dank dank 0 Jun 4 16:14 Music
drwxrwxr-x 1 dank dank 0 Jun 5 16:28 Music Production
drwxrwxr-x 1 dank dank 0 Jun 5 01:11 Phone Backups
drwxrwxr-x 1 dank dank 0 Jun 4 16:15 Programs/Apps
drwxrwxr-x 1 dank dank 0 Jun 4 16:09 TV

the second command gives me

dank 7998 5446 0 21:11 pts/129 00:00:00 grep --color=auto plex

Sorry as you want to make it case insensitive so use that below

ps -ef | grep -i plex

with that command i get:

dank 24343 5446 0 21:16 pts/129 00:00:00 grep --color=auto -i plex

That's a bit perplexing as that means plex is not running on the box you are mounting your rclone drive on.

You'd at least see something like:

felix@gemini:~$ ps -ef | grep -i plex
felix        873       1  1 14:34 ?        00:00:39 /usr/lib/plexmediaserver/Plex Media Server
felix       1211     873  0 14:34 ?        00:00:08 Plex Plug-in [com.plexapp.system] /usr/lib/plexmediaserver/Resources/Plug-ins-69560ce1e/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version /usr/lib/plexmediaserver/Resources/Plug-ins-69560ce1e/System.bundle
felix       2131     873  0 14:34 ?        00:00:00 /usr/lib/plexmediaserver/Plex Tuner Service /usr/lib/plexmediaserver/Resources/Tuner/Private /usr/lib/plexmediaserver/Resources/Tuner/Shared 32600 /waitmutex
felix       2320     873  0 14:34 ?        00:00:05 Plex Plug-in [com.plexapp.plugins.trakttv] /usr/lib/plexmediaserver/Resources/Plug-ins-69560ce1e/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Trakttv.bundle

May want to check the the seedbox provider and ask that question as perhaps they are running it differently?

I updated my support ticket with them with all of this info, hopefully they are helpful! Thank you for helping too I will update with what seedhost says.

This is what they told me:

Plex media server on shared servers works with docker. That's why you can have such error. Please ask on rclone forum how to use it this way.

any help would be greatly appreciated <3

I'm not sure anyone could decompile that to figure out what needs to be done. If they support rclone and plex, they should be able to tell you want to point to.

You've done your part as you have it mounted and if they manage plex, they need to add your mount path so it works if they have it setup in dockers. There isn't anything to my knowledge you can do to fix that as that's a docker config on their side.

That would be my undersatnding anyway.

I can explain a bit how it works and what I'd expect to happen.

Your seedbox user is: dank

If it wasn't a shared seed, you'd use allow-other to allow the plex user to see your file. Since it is a shared seedbox, plex would have to run as "dank" for plex to access those files as if you cannot user allow-other, fuse file systems like rclone only allow the user to see them as they are 'user space' mounts.

When you click on your mount at /home14/dank/mnt/gdrive, what does it do? You see no files? I'd expect that to be because docker might be running as a different user? I'm not sure as it's however they have set it up.

They seem to have an install rclone section on their site:


So you've done as much as you can to setup rclone, you need some help from their side.