Rclone mount on rooted Android

Hello, i'm having issue with running rclone mount on Android. Currently, i'm rooted with magisk and installed rclone mount via magisk's "module store". When i send the mount command to mount google drive, the first error is: "ERROR: error reading avalible plugins: Error creating: /.cache/rclone/webgui/plugins/config"

After a few seconds, another error appears: "Failed to save config after 10 tries: Failed to create temp file for new config: open /.rclone.conf094870642: read-only file system"
I tried to grat permissions to rclone via magisk's Mount Namespace Mode (i set it to global) but it didn't work. Also, i tried putting "su" before the command but when i click enter, nothing happened and just entered a new line for command entering. I copied the config from my PC (Windows 10) to Android because of faster setup.

What is the problem you are having with rclone?

Probably permissions issue

What is your rclone version (output from rclone version)

1.53.0 DEV

  • os/arch: android/arm
  • go version: go1.13.4

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Android 9

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount secret: /sdcard/mount/

Why aren't you using the Magisk module's native mount method? I find it works quite reliably and works for most use-cases

This is a known issue and you can ignore it - it is harmless

It looks like rclone can't write to the config file. You can put it somewhere that is writable with the --config directive.

I'm not sure what are you trying to say. I'm using that magisk module

Well but i can't write --config into command cause on android version of rclone, it's impossible to write flags like it. AFAIK

With the rclone module by piyushgarg, the config gets read at install time. Copy your conf file to /sdcard/.rclone and reinstall the module. You don't need to run the mount command, your remotes should mount at /mnt/cloud immediately (or after a reboot)

GitHub - x0b/rcx: Rclone for Android

If you can't get it working, try the above. Works perfectly on my S20 Ultra with an encrypted Google Drive :slight_smile:

1 Like

Got it working after HonzonJ's reply, but thanx anyway for letting me know this is also an option. :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.