Rclone moun in samba share for windows

Hello guys im triying to make a samba share mounting Google Drive with rclone, i have read permissions but write permissions isnt working i tried with this command

Copy 1

But when i tried to write to the share i cant and i receive that error on windows

Copy 2

Thanks in advance

So the samba share is working but the permissions seem wrong?

I suspect that is a problem with the samba export config - what does it look like?

Where i find this to post it?

this is my samba config


comment = needs username and password to access
path = /srv/private/
browseable = yes
guest ok = no
writable = yes
valid users = @samba
create mask = 2755

Note that rclone mounts don’t preserve ownership so it is likely that your user is

What do the ownership of the files in the mount look like? Ie what does ls -l /srv/private look like? Not interested in the file names so you can edit those out if you want.

Try adding --umask 000 to the mount and see if that helps.

Thanks a lot --umask 000 solved the problem

1 Like