Rclone failing to mount all of a sudden

What is the problem you are having with rclone?

The problem is that my mounted folder in my seedbox is empty now, for some reason.

It started when I couldn't play any content from Plex but my Google Drive folder is still there and works.

I tried to remount and cleaning it up because I'd read somewhere that sometimes the cache could cause issues and if that was purged, then the problems would be fixed.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Headless Linux/amd64, my seedbox also lists something called Go version 1.15.5

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Well that's the weird thing. I can transfer files from my seedbox to Gdrive.

The rclone config contents with secrets removed.

remote> 1
type = drive
client_id = 988251451754-jpp0519lrik9equ4mbsq1bic35dbe4ir.apps.googleusercontent.com
client_secret = 
scope = drive
token =
root_folder_id = 0ANiDuSKbvdE6Uk9PVA

A log from the command with the -vv flag

Can't get the log to work, unfortunately.

There's no mount command.

You are running an old DEV version as well as you want to grab the latest.

With no command nor a log file, there isn't much to do as you haven't listed any error to help out with.

I'm not sure I'm allowed since it's running via a seedbox.

But how can it even unmount? It has worked flawlessly for over a year but today it just doesn't mount.

If you can't see anything, you'd probably have to work with your seedbox provider if they are supporting it.

With no data, we can't offer much help.

Damn :frowning:

They said they don't fully offer support which is strange because they helped me set up back then.

Would it just be easier at this point to just make a new mount? The Gdrive is already there so that shouldn't really be a problem.

The best analogy I can make is saying you are sick, but the doctor can't see you nor give you any details.

Without any information other than "I'm sick", I have no idea what to offer.

What are you trying to run? A command? A script? Clicking a button to start it? How do you know it's not working? Is there any output? A screenshot? Anything?

I'm sorry, I'm just so shit at explaining something, I myself have no idea on how it works.

I thought I explained it somewhat in the OP but I'll reword it.

With my seedbox I get a slot: ~/my username. And after Rclone was set up it created a folder to my Gdrive ~/Gdrive. In FTP I could always open the /Gdrive folder and have access to Gdrive. The same with transferring from the seedbox to Gdrive.

Now, there's just nothing. Rclone is still configured and I can the see the folder in FTP but the file size is now just 0kb.

And I don't know why the -vv log file doesn't work it just gives me an error saying it's an unknown command.

How does rclone start? Do you click a button? Does the provider hit something? If the provider can't provide any support, again, I'm not sure what to suggest.

They say it's on all their servers, so I assume it's something that just runs continously.

Is there any CLI I could write that would help you?

If you can't see anything, you have to work with their support to troubleshoot as there isn't anything we can offer.

Alright so I couldn't get an answer from my seedbox so I got impatient and decided to just config a new mount and folder.

Getting it to join up with Google Drive however seems strange, I tried editing the conf. and got this:

Failed to rc: connection failed: Post "http://localhost:5572/home/maltbrew/.config/rclone/rclone.conf": dial tcp [::1]:5572: connect: connection refused

only one running instance can use a single port such as 5572.
seems that there is another instance of rclone running in the background using that port.

I honestly do not know :slight_smile:

I deleted my old mount but I didn't do anything to rclone itself. It's via a seedbox so I'm not allowed to tinker too much with it.

how did you do that, using fusermount or did you kill the rclone mount command?

seems that there is an instance of rclone running and it is using post 5572.
so either kill it
use a diffrent port for the rc port using this

if you want to test the new remote, then do a command like rclone ls remote:
if that works, then try to rclone mount

I just deleted the folder I had previously. I don't know if you read the first post but for some strange reason my rclone folder that was connected to Gdrive just stopped working earlier today. For no reason and unfortunately my seedbox providers don't offer in depth rclone support.

So I've just been pulling my hair out trying to get some help and gettting it back up and running but nothing I do seems to work! I still don't fully get why a mounted folder just suddenly stops working.

not sure what else to tell you beyond my offered suggestions.

  1. kill all running instances of rclone
  2. run a command to test the remote is working

if you do not use a debug log, really no way to know.
make sure to always use a rclone debug log and look for errors.

Yeah, I'll know that till next time.

I tried the ls remote: but all I get is this

Failed to create file system for "remote:": didn't find section in config file

you need to change remote into the name of your remote.
run `rclone listremotes'

Failed to ls: couldn't list directory: googleapi: Error 404: File not found: ., notFound

I have the ID, secret, and verification code.

i cannot see into your computer.
so for every command, run the command with -vv for debug output and post the output.