RClone Directory Empty Mac OS X

What is the problem you are having with rclone?

RClone mount does not create a FUSE drive on OSX, and the local mount point is empty.

Run the command 'rclone version' and share the full output of the command.

rclone v1.58.1

  • os/version: darwin 12.3.1 (64 bit)
  • os/kernel: 21.4.0 (x86_64)
  • os/type: darwin
  • os/arch: amd64
  • go/version: go1.17.9
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Workspace (Google Drive)

rclone mount gdrive-media-crypt: ~/gdrive-local --allow-other --fast-list --dir-cache-time 2h --poll-interval 10s --umask 002 --vfs-cache-mode full --vfs-cache-max-size 100G --vfs-cache-max-age 2h --vfs-read-ahead 2G --daemon -vv 

The rclone config contents with secrets removed.

type = drive
client_id = 444740492806-n3cci9p38910agdqavt168m3g9r0q4u2.apps.googleusercontent.com
client_secret = 
scope = drive
root_folder_id = 
token = {"access_token":""}
team_drive = 

type = crypt
remote = gdrive-media:/media
filename_encryption = standard
directory_name_encryption = true
password = 

A log from the command with the -vv flag

2022/05/01 11:47:57 DEBUG : rclone: Version "v1.58.1" starting with parameters ["rclone" "mount" "gdrive-media-crypt:" "/Users/tstraub/gdrive-local" "--allow-other" "--fast-list" "--dir-cache-time" "2h" "--poll-interval" "10s" "--umask" "002" "--vfs-cache-mode" "full" "--vfs-cache-max-size" "100G" "--vfs-cache-max-age" "2h" "--vfs-read-ahead" "2G" "--daemon" "-vv"]
2022/05/01 11:47:57 NOTICE: --fast-list does nothing on a mount
2022/05/01 11:47:57 DEBUG : Creating backend with remote "gdrive-media-crypt:"
2022/05/01 11:47:57 DEBUG : Using config file from "/Users/tstraub/.config/rclone/rclone.conf"
2022/05/01 11:47:57 DEBUG : Creating backend with remote "gdrive-media:/media"
2022/05/01 11:47:57 DEBUG : fs cache: renaming cache item "gdrive-media:/media" to be canonical "gdrive-media:media"
2022/05/01 11:48:02 DEBUG : rclone: Version "v1.58.1" finishing with parameters ["/usr/local/bin/rclone" "mount" "gdrive-media-crypt:" "/Users/tstraub/gdrive-local" "--allow-other" "--fast-list" "--dir-cache-time" "2h" "--poll-interval" "10s" "--umask" "002" "--vfs-cache-mode" "full" "--vfs-cache-max-size" "100G" "--vfs-cache-max-age" "2h" "--vfs-read-ahead" "2G" "--daemon" "-vv"]
tstraub@Mac-mini ~ % 

Everything has been working great for about...3 years, and all of the sudden, this happens. The local directory I usually mount to is empy. I uninstalled and reinstalled FUSE with no help. If I run this without --daemon there's activity, but the local mount point still appears empty. My Windows machine works perfectly, so there's no file loss there.

Any ideas?

Thank you all, for making having a media server possible!

Sounds like fuse playing up. Since fuse is a kernel extension you might have to reboot to fix it. Did you try that?

@ncw For some weird reason, I had to completely remove rclone, completely remove FUSE (via removal of cache, config files, scouring ~/Library, etc.) and re-do everything. I had a minor panic attack that I had lost my encryption keys, as I use GDrive and wrapped it in an encrypted mount.

HOWEVER, smart me runs a script on OSX to email a copy to myself once per week. I also had a windows machine config that works, so I just popped it where it needed to be, reinstalled FUSE and rclone, re-ran everything, and now we have no issues.

So odd, but my media server wouldn't exist without RClone! Another important piece: I had to go to Security and Privacy AFTER installing FUSE to "allow " it. Odd, but necessary.

Thank you for all you do, and for checking in!

1 Like

Great glad you got it working - sorry you had to do the whole reinstall thing. I'm not very familiar with the ins and outs of macOS so I can't suggest a better way alas.

If the Mac Mini wasn't such a good all in one piece of hardware, I'd probably still have my Ubuntu Lenovo server running!

Seem to have hit another minor snag. Not sure why, but the process seems to be getting killed randomly. It'll unmount and disappear for no reason, and I'll have to run

rclone mount gdrive-media-crypt: ~/gdrive-local --allow-other --dir-cache-time 2h --poll-interval 10s --umask 002 --vfs-cache-mode full --vfs-cache-max-size 100G --vfs-cache-max-age 2h --vfs-read-ahead 2G  -vv --daemon

to get it to kick on again. I use RClone as a back up storage locale for Acronis back ups for my father's auto repair shop stuff, and the Windows machines back up around 5 AM each day. Any ideas on this front?

Check in the system log - it is probably being killed for power management reasons. There are quite a few threads about this sort of thing, alas.

Seems like it, even though I have the power management settings set to always on.

Crap. What's the best course? Ubuntu?

The best fuse support you'll see is on Linux in general so any flavor would be good.

That's going back a ways from my time tinkering in highschool! I'll probably stick with it, since I know it. In theory, I should be able to just grab the config file from either OSX or Windows and drop it in?

Yes the config file is compatible on all architectures.

Today I learned that my Mac mini from 2020 was not compatible with Ubuntu or any other Linux distribution because the Wi-Fi chip doesn’t work. I had a spare Wi-Fi dongle lying around, and that didn’t work at all. Currently reformatting the drive with online recovery to have OS X back up and running. I have to figure out a way to keep the rclone process from getting killed!

Unfortunately, it looks like the hardware limitations of the Mac mini from 2020 have me stuck here. I love the thing because it got an i7 and I put a shit ton of RAM in it.

I couldn’t get any Wi-Fi chip to run, and where the Mac mini lives in my apartment, I can’t have any sort of hard Internet connection. My Wi-Fi always gets me 400 to 500 Mb upload, so it’s not an issue.

Do you think running in docker would help? I’ve never done rclone that way. CC @ncw

I'm not sure if docker on Mac (which runs on a VM) can export a filing system to the host. If it can then it is worth a try to get round the power management thing.

Oddly enough (I know that's been the theme of this post) the refreshed OSX clean install after Ubuntu seems to not * knock on wood * kill the process? It's been running all day and all last night without being killed?

So, so, weird.

Do you have a suggested docker-compose? The folders are empty again.



I'll have to try this. Between empty folders and OSX killing the process, I've hit a roadblock.

I haven't had much luck finding Docker guides for rclone. It looks like its a bit more difficult than a host install?

@Animosity022 @ncw Just had a brain blast. Could I run Ubuntu in a VM and have Rclone run within the VM, and have OS X as the host access it?

I don't know as I don't use a rclone in a docker nor any VMs on a mac so I wouldn't know what can or cannot be exposed.

I'm more a path of less resistance kind of guy and I'd just use a compatible Linux box.