Rclone crypt + ACD_CLI

So kind of like this

Rclone mount is working but I would like to try mounting my ACD with acd_cli just to test some Plex performance. I already have an encrypted folder in ACD with Rclone and Crypt. I noticed in this linked topic that someone mentioned you can mount with ACD_CLI and then decrypt with Rclone by pointing it to that mounted folder. I haven’t been successful. So far I have tried setting up a “Local” remote and also setting up a second Crypt remote that points to this locally mounted folder instead of the remote ACD folder (using same passwords from original crypt).

So how do I mount with ACD_CLI and access data that was previously encrypted via Rclone crypt? Thank you!

You’ll still need to use rclone, but use it to decrypt the acd mount. So you make a crypt remote with remote set to /path/to/acd/mount.

Thank you.

I have tried this but it’s still not working. I used the same 2 password for the original crypt:

type = crypt
remote = /mnt/acdmount
filename_encryption = standard (same as original)
password =
password2 =

what am I doing wrong?

That looks OK - any error messages?

Would I see the ACD_CLI logs?

I’m not sure where acdcli stores its logs. You might need to turn up the logging level.

I’m interested in knowing what you mean by it's still not working - what exactly isn’t working?

Oh sorry, I should say that the files are still scrambled and encrypted. It does not look the same as if I mounted with Rclone.

I found the ACD_CLI logs…nothing out of the ordinary.

btw, I am pointing Rclone Crypt config at the top level ACD CLI mount which is the root mount. Should I mount just the rclone directory?

Yes - that is probably the problem!