Rclone 1.43 -> change in code


#1

Can anyone who made the changes to how Rclone 1.43 ->
Size, Bandwith, Checks, Transferred or Progress Bar is changed from in code and to which code.
This information is important for and could change Rclone Browser code to work…

Tanks…


#2

Before the stats lines look like

Transferred:      0 Bytes (0 Bytes/s)
Errors:                 0
Checks:                 0
Transferred:         1128
Elapsed time:          0s

After they look like

Transferred:   	         0 / 0 Bytes, -, 0 Bytes/s, ETA -
Errors:                 0
Checks:                 0 / 0, -
Transferred:         1128 / 1128, 100%
Elapsed time:          0s

Does that help?


#3

no, the code line that change is and in what doc in master files ???


#4

Rclone must be made with one sort of file code structure…


#5

I think forking rclone Browser and updating it to work with the new output format would be better. I will try to get around that.


#6

I understand now why Errors and Elapsed time still worked in Rclone Browser with Rclone 1.43.1 as they weren’t changed in 1.43, but Transferred (with ETA), Checks and Transferred didn’t work in Rclone Browser because they were changed in 1.43.

I tried searching through the files, but as this is mostly unknown territory for me, I’m not exactly sure what to look for when it comes to the stats. If it’s not too much to ask, could you tell us which files and lines in those files were changed in 1.43 in regards to the stats lines? If we can research those, we might be able to get a completely working Rclone Browser again.


#7

Rclone browser is other dev


#8

what files in Rclone change to make this change?


#9

We’re well aware of that, that’s why we have to know what was changed in order for us to get Rclone Browser working, as the dev has abandoned the project.


#10

I have forked the project and I have taken a look a it. I always thought it was Python, but turns it was C++. No biggy as I used to write C++ as my primary language but I am not familiar with QT for the UI and don’t currently have the time to learn it. I think we could coordinate to write a better rclone Browser from scratch. There’s virtually no replacement for it right now. (There is rcloneOSX, but it seems to have an entirely different purpose - just backups, and well, it’s a native Mac app).


#11

I’m by no means an expert in neither QT or C++, but if you can add something to the code (E.g. job_widget.cpp) then I can add it to the UI (which in this case would be job_widget.ui). I can’t add pages or tabs atm as I’m still learning, but I can add new boxes and add content to those, as long as what I’m adding is in the *.cpp file.


#12

Maybe using a old version of rclone.


#13

I like the idea. :wink:


#14

@jonaknop has submitted a pull request (a compilation of relevant commits) to my fork with a bunch of relevant changes here. He has already built a Windows version which you can get from here.

I guess the next step, after I manage to create binaries for Ubuntu and macOS, will be to create the distributable files.


#15

Is it possible to run this on a Qnap NAS ?


#16

Ok, it took me some fighting and figuring out some stuff. I’m actually not entirely sure if I did this correctly because my binary is 50x times smaller than the original one, mostly because it doesn’t embedded Apple’s frameworks, which shouldn’t even be needed.

I guess run it and let me know if there’s any problems with it.

Sorry for compressing an already small file, but remember .app files are just directory hierarchies, so zipping is the only way I can share it on Dropbox.

Here you go

The next steps are figuring out versioning (at least on macOS, rclone Browser doesn’t embedded versioning on its plist), changing the icon to the new one, and making proper distributable releases, maybe signing them.

EDIT: It’s actually missing the QT frameworks, so unless you install QT manually, the file above will not work. You can do that with homebrew (brew install qt) until I figure out how to include those from the makefile.


#17

I wish rclone browser would be a Python application that way it could be ported easily to QNAP/Synology NAS.

Is there anything planned in this regards ?


#18

It may be this commit


#19

I’m trying to use your compiled Browser for Windows but it doesn’t works to me. Can’t open config menu nor appears the drives already created.


#20

You have to change the RcloneBrowser.exe out with the new then it works!