Plex not recognised Mount on Debian Server


#1

The Command I currently use is - rclone mount gcrypt: /home/tom/GDrive

Everything works on Windows but on my Server PLEX doesn’t load anything.


#2

Does the Plex user have access to see those files? What’s your mount command?


#4

rclone mount gcrypt: /home/tom/GDrive

What do you mean does the user have access? I’m trying to add the Library


#5

You need to add allow-other.

      --allow-other                        Allow access to other users.

#6

Its saying I need to edit the fuse.conf file. But what do I edit?


#7

Make your /etc/fuse.conf look like this.

By default it is commented out:

felix@gemini:~$ cat /etc/fuse.conf
# /etc/fuse.conf - Configuration file for Filesystem in Userspace (FUSE)

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#mount_max = 1000

# Allow non-root users to specify the allow_other or allow_root mount options.
user_allow_other

#8

Yes its working! Thank you very much


#9

Actually I’m still having Issues. PLEX now scans the media but still doesn’t play it. Something is wrong with my Permissions.


#10

If you really don’t care who can see the media on the server, you can add:

--umask 000

That will mount it with rw for everyone.


#11

Sorry for late reply. I would try this but I’m completely fucked up my Server and can’t connect to SSH. I have blocked port 22 apparently.


#12

Oh that stinks!

Do you have a way to start a console on it and maybe get it working again?


#13

I’m in rescue mode but don’t have a clue what I am doing.


#14

If it is a VPS, most providers will give you console access that you can use to just unblock ssh.


#15

Its a Server from Seedhost. I asked them about it and they said they can’t help because its self managed.


#16

I fixed the Server but --umask 000 doesn’t work. It just brings up all the options.


#17

What’s your full command line that you are trying?

rclone version

shows what version?


#18

Never mind got everything to work for now with this command -

rclone mount --allow-other --allow-non-empty gcrypt: /home/tom/GDrive


#19

Oh right, I am sorry as I assumed you had that and should have asked. Happy you figured it out!


#20

Command is not working now. It worked for about a day but now I’m getting the error “Please check the permissions for this file” when trying to play on PLEX.


#21

If you do a “ls -al” on the files that will show the permissions on the file.

You probably need to add the umask to your mount of the permissions are wrong.