OneDrive Client ID & Secret not working

Is there anything I can do to solve this?

how did you create the client id?

did you follow this procedure?
https://rclone.org/onedrive/#getting-your-own-client-id-and-key

so i tried for the first time to setup my onedrive.
as first, i failed with the same error as you.
my mistake was to use the ID.
i tried again, using the value and that worked.

1 Like

Thank you very much! Using value did seem to work. Also unrelated question, but when cloud transfering from Google Drive to Microsoft OneDrive can I use server side transfer? Or is that only from same cloud storage providers i.e. Google to Google or Microsoft to Microsoft?

you are very welcome.

sure, you can try --magic :wink:

2 Likes

joke went way over my head as well :slight_smile:

oh great, use my own posts against me.
i guess the joke is on me this time :upside_down_face:

1 Like

Hello,
When you get rcone token, did you remember add clinet_id and secret?
You should get the token by 'rclone authorize onedrive 'client_id' 'secret' '
Did you forget last two parts?

Not sure if I understand your question. But I removed my client id and secret in the first post so other people viewing this thread couldn't use it.

hi,

the solution was as i described it here OneDrive Client ID & Secret not working - #7 by asdffdsa

for the client secret:
need to use the Value, not the ID

Hello,

I have the same problem, but nothing helps.

There is a mysterious effect! I have 20 accounts and only the created id and secret I created nearly one year ago are working and now this :slight_smile:
I create new credentials and when doing "rclone config" to create remotes, it works and I can choose even the drive id.

Plus: When I start the union in a mount, it works for some minutes and then I receive the "Invalif client secret" error.

It's driving me crazy because I tried it X time and always the same :frowning:

Regards.

Did you try using the value instead of client secret?

Hi,

yes, I used the value. I did it the same way like I did 1 year ago.

And I did it step by step, with to browser windows, so to choose the same options like the credentials which are working.

But I am sure, it is another reason... Because the first time when config with rclone "it works!", it shows me the drive-id and I choose it with typing "0".

Then later, doing the same with this credentials it doesn't work.

Maybe the reason is the high number f remotes? (same IP) But... I don't think so. At work we have a proxy firewall and so everybody has the same IP.

But thanks for your answer!

hi,
if it was true, then my solution would have worked.

better to start a new topic, answer all the questions..
the unions mount is another issue; let's get the onedrive remote to work first and then deal with that in another topic.

Î am focused on the OneDrive issue, too.

And I am goin' nuts trying, studying and I am sure it is on MS side some issue. If the credentials work one time, when creating the remote and a little later not ...

... it is hard to belive that we are not able to create some simple user id & secret :smiley:

--

PS: Did you read on Azure that MS changed some things at creating credentials?

no, i did not, if you have a weblink to share, i will take a read.

i have not used onedrive, tho i have a 1TB account.
i had planned to set it up with rclone but never got round to it.
so when the OP was having problems, i decided to set a remote for rclone.
i followed the rclone instructions to get my own client id and key.
that worked.

yeah, now that you mention it, i did see that when i was setting up onedrive.
i just followed the rclone instructions - Microsoft OneDrive

if you think that those instruction are no longer correct, let me know,
we can create a new post, asking for an update

It says ...

Blockquote 1.
Enter a name for your app, choose account type Accounts in any organizational directory (Any Azure AD directory - Multitenant) and personal Microsoft accounts (e.g. Skype, Xbox), select Web in Redirect URI, then type (do not copy and paste) http://localhost:53682/ and click Register. Copy and keep the Application (client) ID under the app name for later use.

Accounts in any organizational directory (Any Azure AD directory - Multitenant) and personal Microsoft accounts (e.g. Skype, Xbox)
Updated rule is Starting November 9th, 2020 end users will no longer be able to grant consent to newly registered multitenant apps without verified publishers.

And/but you can choose between ...
**1||**Accounts in this organizational directory only (MSSVST only - Single tenant)|
**2||**Accounts in any organizational directory (Any Azure AD directory - Multitenant)|

(1) Doesn't work.


Edit: I'm exploring something really crazy ... I'll be back soon. I have to see if I am right.

Really funny,... what I thought of and wanted to try (I'm not sure, it did not work for me, but there are more possibilities based on that). So I will not try to explain it again, I have copied one part of thestigma explaination .

Maybe it is the same case at OneDrive?

thestigma

So what was the problem? Well - it was ironically exactly what the error said, an API rate-limit .
The thing is, I had separate Oauth client IDs on several unrelated disks, so I was sure this was not an issue to even look into... but there was something I didn't realize until now: Oauth client IDs created inside of the same project apparently share quota - or at least share some form of burst quota. The solution was simply to recreate Oauth client IDs, each in their separate projects . I did this one by one with stress-testing in between and it was really obvious that the separate-project IDs had way more API quota at their disposal. Not only did they finish heavy list operations much much faster, but unlike the other drives they didn't get a lot of 403 rate-limit errors in their logs. As I moved more drives to separate-project IDs the pressure lessened on the remainder and I saw them speed up and get less errors.

Maybe anybody had the same situation? I can't belive that it me who has the only issue.

i like your forum name, kinda like mine,

i am human plus monkey -> jojothehumanmonkey
you are human plus, but what is the plus part?