(Noob) Need help with mount

I am new to rclone but I have mange to set up rclone on my Win10 machine and sync to Google drive with crypt. I also set up rclone browser by kaptainsky. I am using rclone v.1.51.0 and my rclone.conf look like this:

type = drive
scope = drive
token = {"access_token":xxxxxxx
root_folder_id = xxxxxxxxxxxxxxx
client_id = xxxxxxxxxxxxx
client_secret = xxxxxxxxxxxxxxxx
upload_cutoff = 1G
chunk_size = 128M

type = crypt
remote = gdrive:/Gcrypt
filename_encryption = standard
directory_name_encryption = true
password = *** ENCRYPTED ***
password2 = *** ENCRYPTED ***

When I mount both remotes using Rclone browser, everything mounts like it should as Y: and X: on file explorer and I can see all the files correctly. The issues I am having is when I try to copy a file from gdrive to gdrive-crypt, everything looks find but after the files has been transfer it does not show on gdrive-crypt or anywhere for that matter. The reason I would like to transfer this way is because is much faster compare to using a command line since I only have 40Mbps of upload speed and it takes forever specially when transferring a 50G file to stream from GD to kodi. The command line I used is this:

rclone --transfers=32 --checkers=16 --drive-chunk-size=16384k -P copy gdrive:\folder\folder\ gdrive-crypt:

Any help would be appreciated.

I suggest you add "--log-file rclone.log" to your mount command(s) and check to see if there is anything in the log that looks like errors.

can you post your rclone mounts commands for x: and y:

if you rclone ls gdrive-crypt what do you see?

I will add "--log-file rclone.log" and will check for errors and will report back. I don't use a command line to mound X: and Y: . I mount them thru rclone browser.

I ran the command:
rclone ls gdrive-crypt

2020/04/05 08:06:21 ERROR : : error listing: directory not found
2020/04/05 08:06:21 Failed to ls with 2 errors: last error was: directory not found

my mistake,
the command should be rclone ls gdrive-crypt:

I missed it myself. I ran it again this is what I got

rclone ls gdrive-crypt:

52609469996 folder/file
53862288313 Same folder/file#2

It is showing everything that's on my crypt remote.

Here are the commands when mounting with rclone browser:

C:\rclone\rclone.exe mount gdrive: Y: --rc --rc-addr localhost:0 --rc-user=xxxxxxxx --rc-pass=xxxxxxxxx --vfs-cache-mode writes --config C:/Users/Username/.config/rclone/rclone.conf

C:\rclone\rclone.exe mount gdrive-crypt: Z: --rc --rc-addr localhost:0 --rc-user=xxxxxxx --rc-pass=xxxxxxxxx --vfs-cache-mode writes --config C:/Users/UserName/.config/rclone/rclone.conf

i am a little confused.

you want to copy that 50G file from gdrive: to gdrive-crypt:

are you using
rclone mount - copying from Y: to Z: using windows explorer.
rclone copy via the command line, from gdrive: to gdrive-crypt:

Sorry for the confusion.
I want to be able to copy using windows explorer, which it seems faster then using the command line, which is very slow.

never had a situation where rclone mount was faster then rclone copy.

and keep in mind, for that 50G file, you are copying from gdrive: to gdrive-crypt:
rclone will have to

  1. download that entire 50G file, chunk at a time from gdrive: to you local computer
  2. encrypt that chunk
  3. upload that chunk to gdrive-crypt:
  4. process the next chunk

Ok I see. But I have not notice anywhere in my local computer where it was downloaded before been uploaded again. Was I supposed to set up a special folder for that in Rclone browser?

rclone does not download the entire file,

instead, rclone downloads a chunk at a time, encrypts it and then upload that chunk.
a chunk at a time, over and over in a loop. until the entire file is processed.
no hard drive space is used

I see got it. My other question is, I have copy file1 from gdrive: to gdrivecrypt: using windows explorer. But every time I have done that after the transfer is done, file1 never show is gdrive-crypt: or anywhere. But if i run the command line:

rclone --transfers=32 --checkers=16 --drive-chunk-size=16384k -P copy gdrive:\folder\folder\ gdrive-crypt:

It does. Did I miss a step in RcloneBrowser?

i cannot be much help as

i do not use
--- gdrive, except for testing.
--- mounts, as they are very slow and very unreliable on windows.
--- rclonebrowser. i use rclone from command line for backup, not to stream videos.

if you want to understand what is going on, you must use a log file.

Thats ok , I really appreciate your help. I still learned a few things I did not know before. Thanks again. :call_me_hand:

what version of rclone and winfsp are you using?

I am using rclone v.1.51.0 and winfsp is WinFsp 2020.1 B1. I am also using Rclone Browser rclone, v1.9.7.9 beta.

Using the --dir-cache-time flag, you can set how long a directory should be considered up to date and not refreshed from the backend. Changes made locally in the mount may appear immediately or invalidate the cache. However, changes done on the remote will only be picked up once the cache expires.

hey, i just setup rclone as dlna server and i am playing videos from a remote using vlc.
fantastic, seek works instantly.
subtitles also work

rclone.exe serve dlna --addr=:8123 --name=test01 remote:/videos


I will try using the --dir-cache-time flag. On the other hand, I have no problem streaming from Kodi using a webdav on either remote gdrive: or gdrive-crypt. Like you mention it works instantly which surprise me how fast it is. The problem is when I am trying to copy files, from gdrive: to gdrive-crypt, they dont show up using Rclone Browser. But if I move them, they show up but encrypted, again using Rclone Browser. I just though it would be easier to use since I am new to rclone and have a hard time with command lines.

so i did a basic rclone mount and i had the same problem you mentioned.
that copied files and folders do not show up after a copy.

i have been doing some testing and getting good results with

--allow-other --vfs-cache-mode=writes --poll-interval=1m --vfs-read-chunk-size=1M --dir-cache-time=1m