Mounting an Amazon S3 bucket

We are attempting to mount S3 buckets as local drives. We successfully accomplished this in one of our environments, however in the second we are getting an error
"Failed to create file system for mountname:bucketname: LoadCustomCABundleError: unable to load custom CA bundle, HTTPClient's transport unsupported type"

I have looked all over for information and tried everything I can find. Is this a cert issue? http vs https?

This is an error from the AWS SDK... I've not seen it before but it seems to be about loading a custom CA bundle, which you can do with the AWS_CA_BUNDLE environment error.

I think what it is saying is that you can't use a custom CA Bundle because rclone provides its own HTTP transport.

If that is the case then unsetting the AWS_CA_BUNDLE env var should work.

If you need the CA bundle then using the rclone flag --ca-cert might work.

Alternatively placing the ca bundle in one of these places might work: https://golang.org/src/crypto/x509/root_linux.go

I hope that helps!

Thanks this helped..still not quite there but its more of an environment issue I think

1 Like