Mounted Gdrive not responding while opening a shared folder

What is the problem you are having with rclone?

Whenever I tries to open a shared folder in gdrive which is mounted by rclone in windows explorer (My Computer) it turns into not responding and restart the explorer.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 Pro, 64 bit

Which cloud storage system are you using? (eg Google Drive)

Google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

(in nssm argument)

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

If you share your mount command and a log, we can provide some feedback.

Basically, fill out the things in the template.

How to get the log file? Btw I'm a noob and using nssm to run the rsync (rclone) service.

No idea what NSSM is as I'm not a Windows guy.

You'd want to run a command and use the -vv to get a logfile.

hello and welcome to the forum,

for debugging, run the mount command via the command, not using nssm.
nssm just adds a layer of complexity.

what version of winfsp are you using?

you need to describe in detail exactly, what that the problem is.
not responding and restart the explorer is not enough.

NSSM - the Non-Sucking Service Manager. it's a third party app alternate for mounting drive via cmd or batch file. I tried everything and everything works superfine even it's working on rclone browser but not with windows explorer.

since you have not posted your mount command and a debug log, hard to help you.

not with windows explorer
you need to describe in detail what the problem is?

let's say your mount letter is x:
from a command line, try dir x:?

  • with admin rights
  • without admin rights

Can i send you a video log (screen recording) of that issue. I'm really a noob and it's hard to explain the issue in words.

you can upload the video to your gdrive and share it.

Cool gimme some time, I'll do that in a bit

in the mean time, can you post your rclone mount command?

I used nssm and the argument was mount --vfs-cache-mode full Gdrive_dalcop8:/ g: --config "C:\Users\Deep.config\rclone\rclone.conf"

best not to use nssm for now.

as a test:

  • from the rclone command line, run the mount command.
  • then open another command line and run dir g:

Yeah, i tried that without nssm, and i used that command, everything works superfine like uploading or downloading a file expect downloading or viewing a large file (<100) or a file which is in subfolder with file small files (e.g. an image.jpg), whenever i tries it keep saying not responding but it works with rclone browser

windows explorer, can be a problem.
it likes to scan files to create thumbmails, previews for the preview panes and on.
i have not use windows explorer in 10+ years.

did you try this?

No I didn't, how to do it? Can you explain it to me please?

Yeah it's a problem of windows explorer cause i tried in Mac OS it works fine, can you please suggest me how to do it windows

as a test,
on windows explorer, disable thumbails, preview pane and details pane
set the view to list

add the following flags to your command and try to open a folder with lots of small files.


and post a screenshot of when windows explorer slows down on a folder with lots of small files.

Thanks, but where I'll add this flags like can you gimme an example ? Like should i add in Mount command?

read this
Windows explorer freeze
Looking for a fast and pleasant way to explore my mounted Google Drive

1 Like