Mount Volume on Windows for All users

I am trying to mount an SFTP Share on a Windows Terminal Server 2016 Standard for all users.

What is the problem you are having with rclone?

I can mount the volume as SYSTEM User, than it is accessable from all users, but i cannot modify existing files, as discussed in this thread:

if i mount it as another user, the drive letter will only be available for this specific user!

Run the command 'rclone version' and share the full output of the command.

rclone version
rclone v1.62.2

  • os/version: Microsoft Windows Server 2016 Standard 1607 (64 bit)
  • os/kernel: 10.0.14393.5786 Build 14393.5786.5786 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

SFTP, as said

The command you were trying to run (eg rclone copy /tmp remote:tmp)

"C:\Program Files\rclone\rclone.exe" --no-console --config "C:\Program Files\rclone\rclone.conf" mount Comfine:/ s:\ --network-mode

is exectued via planned task

The rclone config contents with secrets removed.

type = sftp
host =
user = root
pass = secret
key_file = C:\path_to_my_private_key.pem
key_file_pass = secret
shell_type = unix
md5sum_command = md5sum
sha1sum_command = sha1sum

hello and welcome to the forum,

did you try the example from the docs?
-o UserName=user123 -o GroupName="Authenticated Users"

well, yes! following options fixed all my problems:

-o UserName=Administrator -o GroupName="Authentifizierte Benutzer" -o FileSecurity="D:P(A;;FA;;;WD)" --no-console --config "C:\Program Files\rclone\rclone.conf" mount Comfine:/ s:\ --dir-cache-time 1s --network-mode

thanks for the hint!


are non-admin users able access the mount?

yes, they are! :slight_smile:


still running rclone mount as system user?

using NSSM or task scheduler or what?


Task Scheduler! :slight_smile:

is there a FileSecurity="" setting suggestable for b2 ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.