Mapped NAS drive not working as source


#1

I have searched and read through this thread… Mapped NAS drive share not working as source

Doesn’t seem like the user found a solution.

I am attempting to copy files from a NAS share to s3.
Copying from a local drive to s3 works. rsync copy c:/x s3:x
Copying from the NAS share to s3 does not.
I have tried typing the source out differently such as
z:\mjrnas\backups\veeam\DFWHDC and \mjrnas\backups\veeam\DFWHDC

I always receive ERROR: reading source directory: directory not found.

I’m sure I’m leaving out details that may help, please let me know if you need more.

It is possible to use a shared drive as a source, right?
Do I need to set up the shared drive as a remote maybe?


#2

It should be, yes

You shouldn’t need to do that.

Can rclone see the root of the drive?

what happens if you do

rclone lsf z:\
rclone lsf z:\mjrnas
rclone lsf z:\mjrnas\backups
rclone lsf z:\mjrnas\backups\veeam
rclone lsf z:\mjrnas\backups\veeam\DFWHDC

Does it stop working at some point?

You could also try the nounc trick here: https://rclone.org/local/#long-paths-on-windows


#3

None of the above commands return any results. I only receive “error listing: directory not found”

In reference to the nounc page you linked…As I’m new to rclone, I’m not sure where the .rclone.conf file is located. It’s not in my c:/program files/rclone folder. I’m assuming this is not located in rclone config - as that’s where I setup remotes.

I followed this guide https://willhaley.com/blog/install-rclone-on-windows/ (which seems to be pulled directly from git).

As stated above, I have successfully sent object to my s3 bucket with a local disk source. So, I know that parts working at least.


#4

:frowning:

But if you do the ls z:\ and ls z:\mjrnas\ in a cmd windows that works OK?

rclone config file will tell you where the config file is.

It is easiest to make the new remote with the configurator though:

$ rclone config
e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config
e/n/d/r/c/s/q> n
name> nounc
Type of storage to configure.
Choose a number from below, or type in your own value
 1 / Alias for a existing remote
   \ "alias"
[snip]
24 / http Connection
   \ "http"
Storage> local
Disable UNC (long path names) conversion on Windows
Choose a number from below, or type in your own value
 1 / Disables long file names
   \ "true"
nounc> 1
Remote config
--------------------
[nounc]
type = local
nounc = true
--------------------
y) Yes this is OK
e) Edit this remote
d) Delete this remote

#5

OK, so in a cmd window, outside of the rclone folder. I’m not finding the directory using dir z:/
So, that’s interesting…the drive IS MAPPED and I can access it just fine.

After adding the nounc - I’m receiving the same error.

Thanks for sticking with me ncw, I’ll take any advice you throw my way.


#6

Hmm, well rclone works as if in a command windows, so getting dir to work in a cmd windows is what we need to fix.

I did a bit of searching but I couldn’t find anything immediately relevant. Maybe try unmapping it and mapping it again in the turn it off and on again tradition?


#7

This could a permission problem. Network shares are only visible for the user who created them.

The cmd you opened inside the rclone folder was probably a admin process which can’t see your user share.