macOS Catalina and Fuse Mount error

What is the problem you are having with rclone?

I am trying to mount an encrypted google drive on my Mac running Catalina, it is giving an error on the mount.

I can browse, copy etc normally to the same config entry, just mount that is not working.

What is your rclone version (output from rclone version)

rclone version
rclone v1.51.0
- os/arch: darwin/amd64
- go version: go1.13.7

Also using Fuse version 3.10.4

Which OS you are using and how many bits (eg Windows 7, 64 bit)

macOS Catalina 10.15.3

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount -vv media: ./rclone_mount

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

rclone mount -vv media: ./rclone_mount
2020/03/17 10:27:19 DEBUG : rclone: Version "v1.51.0" starting with parameters ["rclone" "mount" "-vv" "media:" "./rclone_mount"]
2020/03/17 10:27:19 DEBUG : Using config file from "/Users/username/.config/rclone/rclone.conf"
2020/03/17 10:27:21 DEBUG : Encrypted drive 'media:': Mounting on "./rclone_mount"
2020/03/17 10:27:21 Fatal error: failed to mount FUSE fs: exit status 1

Hmm, that isn't a very helpful error message.

Have you tried the usual uninstall and re-install routine?

Maybe try a full path to the mount point?

Not sure! Is there any other info anywhere else?

Yeah I was hoping that double verbose mode would give a bit more information, I have a feeling its an issue with fuse and this is the only output it is giving.

I installed both rclone and fuse use brew, I'll try removing fuse and manually install first.

I tried the absolute path first actually, just switched to relative for debug.

You can add --debug-fuse to the mount command to see the fuse debug messages too.

Good idea. It might be worth looking in the kernel log too.

ahh thank you, I'll try that now

Doesn't look like debug made any difference:

rclone mount -vv  --debug-fuse media: ./rclone_mount
2020/03/18 08:32:21 DEBUG : rclone: Version "v1.51.0" starting with parameters ["rclone" "mount" "-vv" "--debug-fuse" "media:" "./rclone_mount"]
2020/03/18 08:32:21 DEBUG : Using config file from "/Users/username/.config/rclone/rclone.conf"
2020/03/18 08:32:22 DEBUG : Encrypted drive 'media:': Mounting on "./rclone_mount"
2020/03/18 08:32:22 Fatal error: failed to mount FUSE fs: exit status 1

I'll try the uninstall process.

And what do you know, removed the osxfuse that homebrew installed and installed using the developers dmg. working fine now.

Thanks all for your help.

Well that is a little surprising, but if it works, lets roll with it!

Do you think it might be worth reporting a bug on the brew package?

When you used the brew package, did you go through and enable the kernel extensions? It sounds like you installed, but didn't really enable it.

yeah I'll look into raising an issue there

seems like i have same problem. Fuse installed

bash-3.2$ sudo rclone --vfs-cache-mode writes mount --allow-non-empty onedrive_remote: ~/Documents/OneDrive/Movies 

sudo: setrlimit(8): Invalid argument

2020/04/05 13:17:19 mount helper error: mount_osxfuse: mount point /Users/alex/Documents/OneDrive/Movies is itself on a OSXFUSE volume

2020/04/05 13:17:19 Fatal error: failed to mount FUSE fs: mount_osxfusefs: exit status 64

That looks like you are trying to mount an rclone mount onto a place where it is already mounted or part of another mount?

You meen, that mounted folder for media shouldnt be in original onedrive folder?

You can't mount something on top of an existing rclone mount.

Do you have an existing rclone mount?

Yes. I'd configured onedrive mount.
Now I deleted OneDrive app and want to mount to another folder.

alex@Alex-MacBook-Air ~ % sudo rclone mount --allow-non-empty onedrive_remote:/ /Movies/
sudo: setrlimit(8): Invalid argument
2020/04/06 21:53:56 mount helper error: mount_osxfuse: /Movies: Read-only file system
2020/04/06 21:53:56 Fatal error: failed to mount FUSE fs: mount_osxfusefs: exit status 64

Copied directly from Apple KB - About the read-only system volume in macOS Catalina*

With macOS Catalina, you can no longer store files or data in the read-only system volume, nor can you write to the "root" directory ( / ) from the command line, such as with Terminal.

macOS Catalina runs in a read-only system volume, separate from other files on your Mac. When you upgrade to Catalina, a second volume is created, and some files may move to a Relocated Items folder.

macOS Catalina runs on a dedicated, read-only system volume called Macintosh HD. This volume is completely separate from all other data to help prevent the accidental overwriting of critical operating system files. Your files and data are stored in another volume named Macintosh HD - Data. In the Finder, both volumes appear as Macintosh HD.

enter image description here

You can just use a simple mount command and pick a directory that exists most likely and is also empty.

I used a test directory in my downloads:

cd Downloads
mkdir Test
rclone mount gcrypt: /Users/textere/Downloads/Test -vv

Running with sudo means you have to configure rclone under root and do your config there.

Non empty is just bad as it allows for over mounting and things to be hidden.

1 Like

I understand this.
Now I created folder on /System/Volumes/Data/FOLDER_NAME and tried to mount onedrive.

Get this answer :frowning:
2020/04/06 22:11:34 INFO : One drive root '': poll-interval is not supported by this remote

I'm going crazy :roll_eyes:

That's a normal message for OneDrive as it doesn't support polling.

1 Like