Listing team drives failed Error

What is the problem you are having with rclone?

I can't seem to access my shared drives (TD) when setting up my rclone remotes. I previously created and used several remotes successfully without any hitches. I had to delete and create the remotes afresh for some personal reasons.

I have tried adding the Team Drive ID manually to the rclone.conf file but still I get errors when running tasks.

My ultimate goal is to use Autorclone/gclone. This isn't my first time using these tools.

What is your rclone version (output from rclone version)

v1. 52. 2

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Android OS 7 running rclone via Termux

Which cloud storage system are you using? (eg Google Drive)

Google Shared Drive (Team Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config
rclone copy rclone_remote:/folder_name rclone_remote:/folder_name -vP
rclone lsd rclone_remote:/folder_name

The rclone config contents with secrets removed.

N. B. Random numbers have been used to hide personal details. 

type = drive
client_id =
client_secret = kleix10GvobsjekemwhwlalsdfFY
scope = drive
service_account_file = /data/data/com.termux/files/home/AutoRclone/accounts/djsnsnwkcfd43339d0a5fbsbsjwbvhasjbwirmemsb6e59a647.json
service_account_file_path = /data/data/com.termux/files/home/AutoRclone/accounts/
shared_with_me = true
server_side_across_configs = true
team_drive = bekwsnsk456knUSmEBDnskw12346nwn

A log from the command with the -vv flag

Failed to copy: couldn't list directory: Get oauth2: cannot fetch token: Post dial tcp: lookup on [::1]:53: read udp [::1]:53296->[::1]:53: read: connection refused
Failed to lsd with 2 errors: last error was: couldn't list directory: googleapi: Error 404: Shared drive not found
Listing team drives failed: Get oauth2: cannot fetch token: Post dial tcp: lookup on [::1]:53: read udp [::1]:45398->[::1]:53: read: connection refused

Thank you in anticipation.

hello and welcome to the forum.

termux is great, especially using the ssh server.

that looks like there is an issue with ipv6 dns server.

not sure what the solution is but as a test, i would try to use --bind to a ipv4 address of the android device

have you tried to copy that config to another device and run a rclone command?

No i have not tried the config on another device. Perhaps I should. Will revert ASAP once I do. I will also read the rclone documentation on -- bind

Thanks for the prompt response.

P. S.
I was previously using rclone on thesame android device and it was working seamlessly. I wonder why such issues should arise now. I also recently updated the rclone version from v1. 52.1 to 1.52.2. I dont remember experiencing this issue before the update.

can try 1.52.1 and let us know what happens?

Tried on another phone (my bro's phone) running version v1. 52.2. Same error. But the lsd cmd runs smoothly using the 2nd phones remotes.

I copied my rclone config entries to his and edited his own to add one of my TD remotes.

you started with the idea that, on your phone, something changed between 1.52.1 and v1.52.2.
let's confirm that before trying the bro's phone, two different config files on two different phones.

did you edit your post or did i miss something.
there seems to be two errors now.
Error 404 is usually a permissions error.

let's pick one error and try to fix that before complicating it with a second unrelated error.

also, if you post a debug log, please post the command, thanks

Still trouble shooting

rclone version --check

Returns this also:

yours:  1.52.2
2020/08/02 19:48:45 ERROR : Failed to get rclone latest version: Get "": dial tcp [2a02:24e0:8:61f9::1]:443: connect: network is unreachable
2020/08/02 19:48:45 ERROR : Failed to get rclone beta version: Get "": dial tcp: lookup No address associated with hostname

this is looking like another network issue.

Oh. Noted. Just reading this.

rclone version --check

can you try that using

  • wifi
  • cellular - disable wifi

Well i rẹ-tried the version check both on WiFi and cellular network (after putting the network off and on). It worked on both occasions. Albeit the lsd and other cmd still don't work.

I can't know how to downgrade to v1. 52.1 on android with termux. Any guides pls? Or can you walk me through the process Pls?

perhaps it was a glitch with the phone.

no need to downgrade.
rclone is just a single file you can download from the website.
you can have mulitple version of rclone.

what i would do is

  1. copy rclone to rclone-1.52.2
  2. download rclone 1.52.1 to a local folder and name it to rclone-1.52.1. move it to the rclone folder.

then run commands like
rclone-1.52.1 version --check
rclone-1.52.2 version --check

This was exactly what I did but it didn't work. So I thought to ask on here. Perhaps there is a better way to go about it.

Thanks for your time and effort. Really appreciate it. What would you advice I do next?

not sure what to tell you now.
except that rclone, like any program, is a single executable file that can be downloaded, renamed and executed.

what exactly did not work?
what command did not work and what was the debug output?

I meant running the version check cmd on the downgraded version of rclone 1.52.1
Here is what I did: downloaded the v1. 52.1 from the github release page and extracted the contents to a specific folder on my phone. Ran the rclone-1.52.1 version cmd within this folder and I get this mesage as output:

rclone-1.52.1: command not found

the extracted file name is rclone, not rclone-1.52.1.
so if you are within the extracted folder, the just rclone version --check

Tried this also. The version check cmd was run within the newly downloaded and extracted rclone v1. 52.1 directory. It returned the version number of the recent release v1. 52.2

not sure what you tried?
you need to post the command line and output.......

i am a windows user, not a linux expert.
you need to cd into that extracted folder and run ./rclone version --check

I am also not a linux power user. Still trying to get my hands dirty learning it and getting the hang of it.

Here is the code I ran:

./rclone version --check
yours:  1.52.1
2020/08/03 05:14:38 ERROR : Failed to get rclone latest version: Get "": dial tcp: lookup on [::1]:53: read udp [::1]:53451->[::1]:53: read: connection refused
2020/08/03 05:14:38 ERROR : Failed to get rclone beta version: Get "": dial tcp: lookup on [::1]:53: read udp [::1]:35263->[::1]:53: read: connection refused

So you can see from the output that the problem still persists even with v1. 52.1

Thanks for your efforts in trying to help me resolve the issue.

You can disable/enable the go dns server vs the system one like this

export GODEBUG=netdns=go    # force pure Go resolver
export GODEBUG=netdns=cgo   # force cgo resolver

So can you try

GODEBUG=netdns=go ./rclone version --check


GODEBUG=netdns=cgo ./rclone version --check

Hopefully one of these will work.