Listing team drives failed Error

Thanks @ncw.
Just tried using your instructions. Same error reported. Here is what I did.

1st I ran

export GODEBUG=netdns=cgo


GODEBUG=netdns=cgo ./rclone version --check

Then, I got this output

yours:  1.52.1
2020/08/03 13:04:55 ERROR : Failed to get rclone latest version: Get "": dial tcp: lookup on [::1]:53: read udp [::1]:42337->[::1]:53: read: connection refused
2020/08/03 13:04:55 ERROR : Failed to get rclone beta version: Get "": dial tcp: lookup on [::1]:53: read udp [::1]:53377->[::1]:53: read: connection refused

Quite frustrating I must admit. :slight_smile:

did you try to bind to a ipv4 address?

I don't know how to go about this. Can you please guide me on how to do this.

I just noticed that the rclone cmds seem to work well with Google drive remotes. The problem arises when I try to run cmds on Google shared drives/Team Drives.

about the export the ncw mentioned, he gave you two options.
and it looks like you tried just one of them?

and this should have nothing to do with google

./rclone version --check

I did try both. I didn't want to litter the post with multiple error reports. They both gave similar output.

I am currently trying out something and it looks promising. Will update ASAP. I need to confirm and be sure first.

Thanks. You've really been of immense help.


Well it seems the problem was from my TD. Apparently the TD had reached its limit file-wise. It could no longer accept files/folders because of this. I noticed this when I tried to make a new directory to dump the files I wanted to copy from a Google drive shared link.

rclone mkdir td:/folder_name

I got this error message

Failed to mkdir: failed to make directory: googleapi : Error 403: The file limit for this shared drive has been exceeded., teamDriveFileLimitExceeded

I wonder why all the rclone rclone cmds I ran (such as lsd, lsf, etc) also failed to work on the culprit TD. My TD is still very much active, accessible and functional.

I tried thesame cmds on a different rclone TD remote and gdrive remote. There were no issues or errors reported.

I eventually tried to delete files on the culprit TD and also from the trash, both on my gdrive and the culprit TD. Apparently I had huge terabytes of files in the trash I hitherto didn't pay any attention to. I had to use rclone Cleanup and delete cmds on both gdrive and culprit TD remotes to empty the trash (still yet to be completed by the way). This thread was helpful Empty Google Drive Trash
I am still working on identifying some of the other issues. I will update this thread when I have more info.

Here are some picx.

1st pic: current state of my drive even after deleting all contents in the trash of my drive and culprit TD. This notification came up after I tried to manually delete the tons of files from my trash. The files were being sent to the bin hence the reason why my gdrive space was filled up in no time (I guess).

Note that I have run rclone Cleanup and delete cmds on both remotes but I am surprised the red alert still persists despite the trash showing nothing in the trash. I would appreciate any help in this regard.

Pic 2: the error message I got when I tried creating a directory in the culprit TD. I began to suspect the TD when I saw this error message and I decided to empty my trash afterwards. Before now, I don't really remember ever deleting my trash.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.