Large appdata folder size

What is the problem you are having with rclone?

Is there a way to reduce appdata folder size or move the appdata folder to another drive?

  • C:\Users\Username\Local\Appdata

Run the command 'rclone version' and share the full output of the command.

PS C:\Windows\system32> rclone version
rclone v1.59.0

os/version: Microsoft Windows 10 Home 21H2 (64 bit)
os/kernel: 10.0.19044.1865 (x86_64)
os/type: windows
os/arch: amd64
go/version: go1.18.3
go/linking: static
go/tags: cmount
PS C:\Windows\system32>

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

I used a mounted drive (via rcloneBrowser) to sync large data (via another program)
Now I have noticed the C drive is full and looking for best method to clear/move appdata
How do I clear the folder?
If i transfer data via mounted drive, will this occur again?
Is there a way to mount a drive (via rclonebrowser) without this occuring?

- I only mount these cloud services as/when required (eg once a week)

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

rclone local appdata

not seeing how rclone can help with that.

for appdata, cannot simply move those files, that would break windows.

for something that, i use freemove

Since you're caching data it needs to be written somewhere. You can change the location with --cache-dir.

See Vfs-cache-mode writes How to change directory? - #10 by Animosity022

I guess --vfs-cache-max=10M would automatically reduce the cache to this size after the modified files have been uploaded.

how do I add to browser preferences?

This is exactly what I would try, do you get an error?

may i ask the the reason to try remove appdata to cloud and that total size of appdata?
running low on local storage space or what?

not sure that is a valid flag.

and in any event, a value of 10M is not going to be vert effective.
rclone cannot remove in-use/open files from the vfs file cache.
think about the firefox cache, the number of files being changed/deleted/open/in-use per second.

and gdrive and perhaps plcoud, are severe api limits, can transfer approx. two files per second.

I may be wrong, but it is my understanding that @Terry99 has made the mounts using the RcloneBrowser and that it by default stores the rclone cache in AppData. Thus the need to move or clear the rclone cache taking a lot of space in AppData.

You are absolutely right, I mean --vfs-cache-max-size

My intend with a very low value is to make it work much like --vfs-cache-mode=off, because I noted that it was set to "write" in the fist post. I guess the cache is only needed while the files to be uploaded are being written by some app, perhaps a backup.

I am sure you know mounts better than me, and probably also the RcloneBrowser, so your input is much appreciated - we just need to make sure we understand @Terry99's situation correctly.

i think you are correct


The reason I started looking into this was due to C drive becoming full.

  • I mounted a cloud drive (via Rclone browser) and performed a sync between local storage and cloud storage and then noticed C drive full.
  • Using TreeSize Free I found the large appdata folder which when I open further, has folder/files that match the sync I did.

As I would like to use the mount drive more, but need to address the appdata issue as C drive is full.
My computer language skills are somewhat limited so not sure best way forward. I figured someone must have come across this before.

This is correct.

I am unable to mount the cloud via powershell (see my other thread) so was happy when rclone browser mount worked.

As asdffdsa commented, "windows maintains two separate lists of mapped drives for a give username

mapped drives for command prompts with admin privileges
mapped drives for command prompts without admin privileges.

if you run a rclone mount with admin privileges.
then windows explorer, which runs without admin privileges, will not see the mount.
one workaround is to mount to a folder, not a dir, tho that is not what you want."

By your suggestion, maybe if I can work out mounting via powershell, I won't have this problem with appdata, which also makes sense.

Can I change where the cache /appdata is stored?

I found:

If the above max size and alternate drive are an option,

  1. can I use it within the rclone browser
  2. do I add it to browser preference mount options
  3. do I need quotes around each option

The appdata folder has a full/usable copy of the files synced

Out of interest,

  • I deleted the remote (rclone config) but appdata remains
  • ran diskcleanup (admin) but appdata remains
  • uninstalled rclone browser but appdata remains
  • ran diskcleanup (admin) again but appdata remains
  • I deleted the folder within the appdata containing all the synced files and my C drive is back to normal

Folder where data deleted:

I'll update if I notice any negative consequences, but it appeared there was nothing within the folder other than a full copy of all the files I had synced

It would be interesting to see if I can choose where this vfs data was saved (eg an external harddrive) or only as temp files

what are the correct mount options in rclonebrowser for above issues?

I don't know RconeBrowser and is unable to spot the issue from the 2 screen shots.

Your mount options looks correct to me, but rclone apparently complains about the the (wrong/misplaced) parameter "Cache\"" which I cannot see in the screen shots. It could be an issue with the way RcloneBrowser passes quoted parameters to rclone. It would perhaps be possible to spot/explain/workaround the issue if we could see the full rclone command issued by the RcloneBrowser, but it may require some trial and error.

I therefore think we will be better able to help you if you execute your rclone commands directly from PowerShell and responded to your previous thread to see if we can easily get you into a non-Admin PowerShell.

--- can you post the entire debug log, not just a snippet.

--- --fast-list does nothing on rclone mount

apologies for insufficient info

See attached:
Scenario 1 settings (as above) error info attached below
Scenario 2 works fine

Scenario 1 error:
scenario 1 error.txt (4.9 KB)

no negative consequences.
appears like it was a simple duplicate of files I synced

@asdffdsa is not referring to the output showed by RcloneBrowser, but the debug log you get when starting rclone in a terminal (Powershell) with the -vv option, e.g. like this

./rclone mount pcloud: Z: --vfs-cache-mode full --cache-dir "D:VFS Cache" -vv

RcloneBrowser is a tool that was built on top rclone and as such not really supported in this forum. Additionally the developer has put this on the RcloneBrowser project page:

WARNING: This project is not longer active or maintaned.

Initially I created it only because rclone mount did not work in the beginning. Now mount on Windows works fine, so this project is not useful for me anymore.

I suggest to try out rclone built-in web based GUI instead

I furthermore think I have solved your original issue with starting rclone as local user.

This will hopefully give you a nice ride without needing the RcloneBrowser :sweat_smile:

Yes - thanks for your assistance (painful I'm sure :wink:)