Im lost, please help

#1

Im just having tons of issues getting rclone cache to actually work. All movies buffer and some won’t even play. Latest version of rclone. I made a test cache with just three movies so the logs were smaller and I could get everything done faster in terms of support.

I have tried with and without sudo on these commands
Below is a test run with the complete set up and, plex scan, and all three movies during playback with -vv output

https://pastebin.com/LV7Pp9zX movie 1

https://pastebin.com/k2eUcaY5 setup/scan

Please help im lost.
Next 2 movies in next post

0 Likes

#2

https://pastebin.com/LgfXQ0UC movie 3

https://pastebin.com/fzRucLYA movie 2

0 Likes

#3

There’s no reason to really use the cache.

Just use a mount command with all the defaults.

Did you make your own client ID/API Key?

https://rclone.org/drive/#making-your-own-client-id

0 Likes

#4

I’m using my client id and api key. I thought the whole reason of the cache is stop the api bans… are you saying cache or the vfs are no longer needed for this? They have been rendered obsolete for this?

Sorry just everything inhave read says to use the cache. Just don’t want to get banned for 24 hours lol.

0 Likes

#5

Regular vfs works fine.

0 Likes

#6

So I tried the regular mount options but it’s performing worse then the cache

0 Likes

#7

Did you make your own client ID/API key? What mount options did you use?

0 Likes

#8

Yes I did create my own id and api key

My mount command is
Sudo rclone mount --allow-other --allow-non-empty -vv Gdrive: /Volumes/plexdrive

0 Likes

#9

Post a debug log. And what do you mean “performing worse”. The Plex scan is slower?

You should consider setting the dir-cache-time time to a very high number. And rely on the change api to update the mount with changes. The first scan will be slow. But the next should then be very fast.

0 Likes

#10

No like play back was buffering even more. I only did a few movies in a test directory for quicker scans until it actually works.

0 Likes

#11

Well I got an api ban for that regular mount…
Or possibly because I have tried too many times to get this working. Idk. Can’t do much now.

0 Likes

#12

What does

rclone version

show?

0 Likes

#13

Davids-iMac:~ david$ rclone version

rclone v1.46

  • os/arch: darwin/amd64

  • go version: go1.11.5

Davids-iMac:~ david$

0 Likes

#14

Yeah, you don’t get API bans on that version so not sure what you are referring to.

If you got a log, please share.

0 Likes

#15

ok I will remount and try and play a movie. how can you not get api bans?? I thought that was the reason of using Rclone with Plex instead of using google file stream for Mac or windows?
sorry just confused. log is coming give me a few minutes

0 Likes

#16

whats the easiest way to get you the log?

0 Likes

#17

Anyway you want.

pastebin / dropbox / etc.

You can zip it up and upload it here.

As I said before, you don’t get bans using rclone.

0 Likes

#18

log

https://pastebin.com/inzyfyFx

0 Likes

#19

What are you trying to play?

There isn’t much of that log to look at as it’s only a few lines and nothing looks like it is being played.

0 Likes

#20

here I’m trying to play infinity war in 1080 and 4k. and black panther at 1080. lots of buffering issues towards the end of each one when I decided to quit out and try and another movie
https://pastebin.com/YXAgbNsD
https://pastebin.com/prCn4JLM

0 Likes