I want to use Rclone to batch rename files on my mega app

I want to be able to mount my mega account onto my computer using Rclone. I am a MacBook Air M1 user. I am also running into several problems.

  1. Rclone says it will not run because there are multiple (Application)

  2. I am having trouble downloading things properly or rather am not sure what I don't have and need, if I need to get rid of things that would be helpful also.

  3. I have tried multiple things in the terminal, I need to know what I am missing to have Rclone fully running and able to mount my mega account onto my computer, ask as many questions so that things can get ticked off, addressed, and solved.

Any guides are helpful, anything is helpful.

The goal is to be able to batch rename or rather just rename multiple files in my mega app

Fill in all details as per Help and Support template as nobody is going to guess:

what you mean and what you are missing.

The first problem I'd say is that Rclone is saying "Rclone Browser is already running.

Only one instance is allowed."

This is rclone not rclone browser forum.

Can you appoint me to how I can get Rclone to mount my mega app while being able to batch rename or rename multiple files? I don't mind starting over

I suggest Google.


I'll check this. Thank you for your fast response

This is what it said " rclone mount remote:path/to/files /path/to/local/mount

2023/06/02 07:32:47 NOTICE: Config file "/home9/skyline/.config/rclone/rclone.conf" not found - using defaults

2023/06/02 07:32:47 Failed to create file system for "remote:path/to/files": didn't find section in config file"

I copied the first code and put it in my terminal

I am sorry but your posts tell me that your computer knowledge is rather limit.

Unfortunately rclone requires some basics familiarity with command line etc.

The best what I would suggest is you ask some friend computer whiz to configure it for you.

And of course you can learn all these things yourself - it is not black magic at the end:)

no point asking smh

hello and welcome to the forum,

the first step should have been you answering all the question in the help and support template???
that way we do not have to pull the required information from you, drip by drip.

so, please post the full output of these two commands.
--- rclone version
--- rclone listremotes

After those were out in this is what my terminal replied

--- rclone version

--- rclone listremotes

zsh: command not found: ---

zsh: command not found: ---

ok, i think you need to:

  1. install rclone - https://rclone.org/install/#script-installation
  2. create and TEST a remote fo mega - https://rclone.org/mega/

This was the Terminals response for the first step I will continue on to do the second thing you sent

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 4707 100 4707 0 0 9533 0 --:--:-- --:--:-- --:--:-- 9586

The latest version of rclone rclone v1.62.2 is already installed.

 rclone config

This will guide you through an interactive setup process:

No remotes found, make a new one?
n) New remote
s) Set configuration password
q) Quit config
n/s/q> n
name> remote
Type of storage to configure.
Choose a number from below, or type in your own value
XX / Mega
   \ "mega"
Storage> mega
User name
user> you@example.com
y) Yes type in my own password
g) Generate random password
n) No leave this optional password blank
y/g/n> y
Enter the password:
Confirm the password:
Remote config
type = mega
user = you@example.com
pass = *** ENCRYPTED ***
y) Yes this is OK
e) Edit this remote
d) Delete this remote
y/e/d> y

This part was successful and I was able to see the files that I have in the mega app in the terminal. Now, how do I mount it so I may batch rename or rename the files that are inside the mega?

On windows I was able to use Air live drive. I shift clicked multiple files and then renamed them. How do I do the same on my Mac book using Rclone?

need to run something like
rclone mount mega: /path/to/mountpoint

Regular Terminal or Mega cmd? does it matter?

I will try the terminal first

This is what the terminal replied:

rclone mount mega: /path/to/mountpoint
2023/06/03 07:42:41 Failed to create file system for "mega:": didn't find section in config file