I made a mistake in the rclone config, how do I go back and change it?


I am new and trying to set up rclone encrypted with my google drive for plex. I am not technical but following this guide:

I am at step 35 of that guide but instead of typing "crypt" I typed gcrypt again!

How do I go back a step in the config to change what I typed or if I just shut the config down will it just forget everything and I can start again?

I don't have any error log to post.

If you saved the config, you can go back and edit it.

If you didn't save the config, you'd have to start over.

Not sure I'd recommend that guide though and it's a year old and wants you to use the cache backend.

Thanks, I still have the command prompt window open, I tried to use the tab up key to edit but it didn't work and now I'm lost. I am worried about what I have already done causing a problem with starting over.

Can you recommend / link another guide that would be better? Something that is idiot proof would be ideal*. I want to set up google drive (gsuite) as a source for plex with rclone and have it encrypted. The above guide does that and seemed to be working but just made that one typo and messed it all up.

If you know of something better that would lead me through it all step by step that would be great.

*It took me ages to workout how to even run rclone config as I had no clue about the command prompt.

Sorry as I'm not a Windows guy so couldn't offer much help other than looking at that guide and it's very dated.

Perhaps someone else can mention a guide for Windows.


i am a windows user

first you need to create a crypt using rclone.
have you done that yet?

Thanks for your help, yeah hopefully someone can help me further with the windows side of things.

Hi I was following the guide I linked to in my first post and then I made an error where I typed gcrypt instead of crypt and now I am stuck. I haven't finished creating the encryption yet because I made a typo. I don't know what to do now.

that is not a good guide.

have you create a working remote for gdrive?
what is the name of the remote?

Honestly I don't really know what you mean by a working remote for gdrive. I have only followed that guide, I got to the point where I authorised rclone to access my gdrive and I made a client ID and Client secret but apart from that all I have done is follow the guide I linked to. I can't yet see the gdrive mapped to my pc.

one of the many problems with that guide is that it does check remotes after creation.

you need to be sure the gdrive: remote works before create others remotes that are based on gdrive:
if you run this command do see the files that are stored in your google drive?
rclone ls gdrive:

I tried to run that it said Error: unknow command "Is" for rclone

I think you could be way ahead of me here as I am not even sure if I am doing what you asked correctly. I feel like at least I could make sense of and get that reddit guide to work until I messed it up with the typo.

Do you know of any guide I can use that would be good to do what I need to setting up google drive ( gsuite) with reclone for google plex? I believe I need to set up encryption but perhaps I don't? I basically don't know what I am doing and need a step by step guide that works.

"it said Error: unknow command "Is" for rclone".
that does not help much.

run that command again,
from the terminal, copy the command and all the output and paste it into a post here.

run rclone version
from the terminal, copy the command and all the output and paste it into a post here.

rclone provides a guide to setup a google drive

C:\rclone>rclone version
rclone v1.52.0

  • os/arch: windows/amd64
  • go version: go1.14.3

C:\rclone>rclone Is gdrive:
Error: unknown command "Is" for "rclone"

Did you mean this?

Run 'rclone --help' for usage.
2020/06/02 14:54:01 Fatal error: unknown command "Is" for "rclone"

Did you mean this?


This is what I got the rclone version info is first.

I am happy to start again and will look at the guide you linked to but do you know if having got part way through this previous attempt will cause me a problem, can I undo it somehow or just ignore it?


Actually I just did the rclone ls gdrive command again and this time I saw my files! I was typing I and not L - oops!

Its rclone ls not is

that is 'LS' not 'is' (except lowercase)

Yeah I just worked that out, so yes I can see my files when I run that command! Sorry for being dense.

the command is correct,

can you typed exactly what i gave you.

l as in the word letter
s as in the word stuff

C:\rclone>rclone ls gdrive:
638692030 Adam Buxton - Ramble Book.m4b

When I typed "rclone ls gdrive" I got the above

I only have the one file on there at the moment so that is correct!


now that gdrive: remote is working,

the guide wants you to create a cache but i would skip that.

instead create a crypt remote, perhaps call it gcrypt
after creating the remote, you can test it. as there are no files in the new gcrypt, you will not see any files yet.
rclone ls gcrypt:

Ok thanks, I will try and work my way through that guide and see how I get on. Thanks for your help, I'll post back here to let you know how it goes!

the next step is to create a crypt, as per the rclone guide, i shared with you.

really, do not use that guide.
it is out of date and gives bad advice about creating a cache.
the rclone cache is beta, has no maintainer, has known bugs that will never be fixed, and as a result, the cache is soon to be depreciated.

please read this