How to upgrade rclone from v1.51.0 to v1.60.1 in the high performance computer

What is the problem you are having with rclone?

I'm planning to back up my data generated in the high performance computer of the uni to my google drive. However, I encountered the error below:
Google Drive - Error 400: invalid_request when access url to for Log in and authorize rclone for access

After searching on the forum it seems to be caused by rclone version issue

The problem is, the version of rclone installed in the hpc is 1.51.0 and I don't think I have access to root to upgrade it. I was just wondering is there any way that I might be able to upgrade the version apart from contacting the hpc maintainance team?

Run the command 'rclone version' and share the full output of the command.

rclone v1.51.0

  • os/arch: linux/amd64
  • go version: go1.13.7

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

You need to use the stable version as that won’t work.

Update and test again.

Yes, but I don't think I can update the version on the high performance computer by installing a new version directly, do I? Since I have no access to root...

No idea on your setup as you don’t need to be root to install it.

There is nothing to do as that version won’t work so you can either get it updated or remain broke.

Google changed their oAurh and that version won’t work.

Could you let me know how to upgrade it without a root? Is there a link to the command that I can probably use? Thank you.

Download the version for your system and unzip it where you need and run it from there.

As I just mentioned, what I meant that I couldn't download or install in the remote machine by root:

I also tried to leave off the sudo from the command and the output is as below:

Is there any solution to that?

Yes, like I shared above.

Download the zip file for the version of your machine on the link I provided so you want to download the zip file and unzip it.

Hello, I downloaded the zip file, unzip it, and then tried to load the new version of 1.61.0 but it showed " ERROR: Unable to locate a modulefile for 'rclone/1.61.0' "

I don't know if I omited any essential step?

Without knowing what OS you are running, it's super tough, guessing it's a very old one?

Hi I'm running all the commands on the high performance computer and it is Linux OS. It's owned by my university (Kathleen - UCL Research Computing Documentation). Don't know if this info helps a bit?

Unfortunately, no, but I relooked at your screenshot and you want to type the binary name. I'm not sure why you are trying module or load or anything else.

You want to move into the directory and run the ./rclone version command and that should show the new version.

Something like:

felix@gemini:~$ wget
--2022-12-22 23:53:13--
Resolving (, 2a01:4f9:c012:7154::1
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 17480206 (17M) [application/zip]
Saving to: ‘’                          100%[===============================================================================================================================>]  16.67M  1.41MB/s    in 30s

2022-12-22 23:53:44 (576 KB/s) - ‘’ saved [17480206/17480206]

felix@gemini:~$ unzip
   creating: rclone-v1.61.0-linux-amd64/
  inflating: rclone-v1.61.0-linux-amd64/README.html
  inflating: rclone-v1.61.0-linux-amd64/rclone
  inflating: rclone-v1.61.0-linux-amd64/README.txt
  inflating: rclone-v1.61.0-linux-amd64/rclone.1
  inflating: rclone-v1.61.0-linux-amd64/git-log.txt
felix@gemini:~$ cd rclone-v1.61.0-linux-amd64/
felix@gemini:~/rclone-v1.61.0-linux-amd64$ ./rclone version
rclone v1.61.0
- os/version: ubuntu 22.04 (64 bit)
- os/kernel: 5.15.0-56-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.19.4
- go/linking: static
- go/tags: none

Hi, I tried to use ./rclone in the directory and this time it worked. And now the version is the latest.

FYI as for the module load command, because rclone was pre-installed in our hpc cluster, according to the uni hpc tutorial we have to run "module load rclone" to load the package.

Thank you very much for your help. Really appreciate it. Wish you a merry Christmas ahead!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.