How to Propery Setup Rclone Mount on Windows using Nssm as a Service?


#1

Hi!

I’m with problem to setup rclone mount as a service om my windows 10 computer.
I must be forgetting something, and I will be very happy if someone could help me with this.
What I have done:
1 - Dowload nssm.exe and move it to same directory that rclone is. In my case c:\rclone.
2 - Typed: nssm install “Rclone Mount” in a promped command on c:\rclone
3 - As argument I have used the some comand I running before to test im prompt:
“rclone mount --allow-non-empty --allow-other --default-permissions Odrive: N --config “C:\Users\Windows-10.config\rclone\rclone.conf””
See pic 1
I’m not sure what I need to type: If is rcloue nount or only mount in Arguments.
4 - I received the message: Service Installed Sucsessfully
The problem is the service start and pause
If I loog in task manager the server was in pause mode.

Please help me.
What I’m doing wrong?


Windows mount with cache for Plex
#2

I would say the arguments should start “mount …” not “rclone mount…” after a quick look at the nssm docs.


#3

Thank you. That’s work pretty fine now.
I’m using the same config I have used in linux to work for streaming plex.
I just have to create the file log.file and the folder to cache, and off course point the config file

mount --log-file “C:\rclone\logs\rclone.log” --log-level INFO --allow-non-empty --allow-other --fuse-flag sync_read --tpslimit 10 --tpslimit-burst 10 --dir-cache-time=160h --buffer-size=64M --attr-timeout=1s --vfs-read-chunk-size=2M --vfs-read-chunk-size-limit=2G --vfs-cache-max-age=5m --vfs-cache-mode=writes --cache-dir “D:\DriveFSCache” Gdrive3: M: --config “C:\Users\Windows-10.config\rclone\rclone.conf”