How to prevent creating duplicate folders in Google Drive with Server Side transfer?

I have a Google Drive remote with a folder Backups in it, and a sub directory games. When I copy files to that folder (using rclone copy [file or folder] Drive:Backups/Games, it copies it to the right folder without creating new folders.

However, when I copy from a Shared With Me folder, using a server-side transfer, it creates another Backups folder, with another Games folder inside of it. This is very annoying, and makes server-side transfers that are over 750gb impossible (because after I receive the ban for the day, and start again the next day, it creates another folder, and copies the same files it did the first time).

Can you give a sequence of commands to reproduce please?

Sure.

rclone copy --drive-shared-with-me "Drive:Shared Folder/Shared Subdirectory" Drive:Backups/Games

is what causes it for me

Ah, I see. The --drive-shared-with-me hides the non shared with me stuff so rclone doesn’t see the existing folder and creates a duplicate. I think the idea behind the flag is flawed but I can’t think of a better way right now… Maybe the shared with me files should appear in a subdirectory. I’ve been trying to avoid that though as it will really complicate things.

Can you make a new issue on GitHub please and we can discuss the best way forward there - thanks.

Ok, posted it here: https://github.com/ncw/rclone/issues/2675