Guide to replaceing plexdrive/unionfs with rclone cache


#81

Just to clarify.

You use vfs for writing TO gdrive
But a regular cache drive for READING to plex?


#82

vfs or cache is on or the other. I use vfs for reading and a rclone move script.


#83

thanks I see you went back to the cache for testing purposes.

Can’t wait till the ATV comes


#84

What’s ATV? Is it a new feature?


#85

I asked the same thing…

Apple TV =P


#86

hey animosity !

Thanks for your great support over here.

I’m an old rclone user who switched to plexdrive because rclone cache was starting my medias in approx 20 seconds while plexdrive achieved this in around 5 seconds.

two days ago, a friend told me to have a look at vfs, which I did. No luck for me, I now have to wait for more than 30 seconds in order to see a movie stream start.

here is the content of my rclone.service (which I adapted to above settings as you stated it starts streams in approx. 2/3 secs for you

ExecStart=/usr/bin/rclone mount
–log-file ${LOGS}/rclone.log
–log-level INFO
–umask 022
–allow-non-empty
–allow-other
–dir-cache-time 96h
–poll-interval 5m
–vfs-cache-max-age 48h
–vfs-cache-mode writes
–vfs-read-chunk-size 10M
–vfs-read-chunk-size-limit 100M
–buffer-size 1G
–config ${RCLONEHOME}/rclone.conf
gcrypted: ${MOUNTTO}

once the movie started, I have no streaming issue…Really looks like the “buffer” is the issue. It takes ages to start a stream, and same when I ff or rw.

Any clue how I could investigate and fix this ?

thanks !!!


#87

Your chunk size is pretty small. I’d turn off all those vfs items and leave it at the defaults as a starting point. I run the same buffer size so I don’t see an issue here.

Are you playing directly from the mount or using unionfs?


#88

Playing this directly from the mount.

I’ve used the vfs settings you posted:

–allow-other
–dir-cache-time 96h
–vfs-cache-max-age 48h
–vfs-read-chunk-size 10M
–vfs-read-chunk-size-limit 100M
–buffer-size 1G
–syslog
–umask 002
–rc
–log-level INFO

I simply left the poll to 5 minutes and told rclone to write to the log file location I usually use.


#89

I’ve probably posted roughly 1,523 settings from testing.

My current settings I personally use are here -> https://github.com/animosity22/homescripts

I’d up the chunk size to 32M and turn on debug and play a file and post that back.


#90

hey Animosity,

just wanted to let you know my problem is solved.
I actually had to create my client_id and secret pswd in the google API admin dashboard.
I reconfigured the rclone gdrive from scratch and added these values.

Now, I don’t have any 403 errors anymore, and everything runs smooth !!!

So sometimes the issue is located somewhere else!

thanks again !!!


#91

With a vfs mount, when a new file is added to gdrive, the mount spots this pretty much automatically via the polling.

Is the same true with a cache mount? If a file is added to gdrive via other routes and not via --cache-tmp-upload-path does the polling stil work and the file will appear straightaway?


#92

Polling is the same regardless of a vfs mount or the cache mount as the default is 1 minute.