Google Drive rclone ls and lsjson returning different results

I would like to list the content of my Google Drive Trash Folder.

Currently my Google Drive Trash contains 2 files

DEl is a folder in the trash

if i run:

rclone ls mydrive: --drive-trashed-only

i get this:
-1 APK/Del.docx
-1 APK/DEl/DEL2.docx
which is fine Del.docx and DEL2.docx was originaly stored in APK folder

But if i run the same command with lsjson a totally different output will be created:

rclone lsjson mydrive: --drive-trashed-only


{"Path":"Adobe Flash Player","Name":"Adobe Flash Player","Size":-1,"MimeType":"inode/directory","ModTime":"2023-04-29T09:00:58.384Z","IsDir":true,"ID":"folder_ID"}
.............a lot more line containing only folders..............

All of the folders in the lsjson output are not in the trash they are in the root directory of my Google Drive.

i have also tested other ls commands:
lsl:given expected output like ls
lsd:same output as lsjson
lsf:same output as lsjson

Is this a bug or I'm missing something?

Thanks for reading


i can reproduce that.

as for what it means, i do not know.

there is a way to use lsf on the trash folder.
check out rclone lsf --format "pM" drive: --drive-trashed-only --files-only --recursive

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.