Give permissions to execute C code in OneDrive mounted folder

What is the problem you are having with rclone?

Hi,
I am new to the Linux world and wanted to mount OneDrive using Rclone. Small issue, I can't run any compiled C script located in my OneDrive mounted folder because I get a bash: ./main: Permission denied error. I tried using chmod +x ./main to give permission to run the C executable but i get the same error.
I'm currently using this command to mount the folder :
sh -c "rclone --vfs-cache-mode full mount onedrive: ~/OneDrive"

Can anyone tell me a way to add permissions to run C executables in OneDrive plz ?

Thank you !

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.2

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 6.5.0-15-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.6
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

OneDrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

gcc main.c -o main && ./main

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[onedrive]
type = onedrive
token = XXX
drive_id = XXX
drive_type = business
### Double check the config for sensitive info before posting publicly

A log from the command that you were trying to run with the -vv flag

Paste  log here

welcome to the forum,

try adding --file-perms=0777

check out my howto guide, tho focused on windows, the same should apply to linux
https://forum.rclone.org/t/how-to-execute-programs-inside-a-mount/12955

check out my wiki, tho focused on windows, the same should apply to linux
https://github.com/rclone/rclone/wiki/how-to-run-.exe-application-on-rclone-mount

Wow thank you, it works now !
I tried to do this but somehow it didn't work at first, I then placed this flag at the end and it works. Thank you :star_struck:

1 Like

ok, good that it is working now

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.