Getting Bad credentials during remote config

What is the problem you are having with rclone?

I have setup an remote via the docs here, towards jottacloud.

When I run rclone config I don't not get the same output as the instructions, for example I never get to the part where I need to crate an machine specific API key.
After Advanced n, I get to remote config and since I am ssh into an server, I say no and run it on my local machine and get to a hubic page where I am supposed to login...
I tried my reclone account and my jotta account, both fails.
I retried and set an clientid, my mail and a client_secret, ran the command I get in the end rclone authorize "hubic" "client_id" "client_secret"

The browser opens and says: Failure!

So now I feel dumbstruck, what am I supposed to use to login?

What is your rclone version (output from rclone version)

rclone v1.49.3

  • os/arch: linux/amd64
  • go version: go1.12.9

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu server 19.04, kernel 5.x

Which cloud storage system are you using? (eg Google Drive)

Jotta Cloud

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone remote config

I would guess you chose the wrong backend (hubic) in the configurator.

Instead of choosing a number you can type "jottacloud" to make sure you get the right one.

More formatting confusion? Hmm... I do notice this seems to happen more than it should for new users.

Indeed... The TUI prototype I showed would help with this probably...

The whole choose a number thing doesn't work very well for long lists.

Maybe I should make rclone config use a more TUI approach and make a backwards compatible rclone tconfig or something.

So instead of choosing the number (in this case 14) for Jottacloud, I should write Jottacloud instead?

14 is Hubic.

15 is JottaCloud:


You can type in 'jottacloud'

No no no no! :smiley: Did make such a simple error? ashamed.

We are merely suggesting that it looks like you were confused by the list - and what numbers corresponded to what option (I agree it could be clearer and we are aware of that). So much text sqashed together with no breaks makes it very easy to make a mistake.

You are not the first one to make this mistake - so every indication is that the configurator needs to be a little more clearly formatted for intuitive understanding.

It is surely a sign that the configurator needs a re-design :slight_smile:

It's never the user's fault as clearly @ncw just designed it poorly :slight_smile:

:slight_smile: I regard reports of user mistakes as bugs which need to be fixed in the code or the docs!

Worst dev ever... shame... ding! shame...

Thank you!
With 15 instead, it is now working! :slight_smile:

How about this as an easier to read interface?


I think that should work on Windows too...

If anyone wants to have a go with that (testing on Windows appreciated!) then (uploaded in 15-30 mins)

Looks good on Mac/Linux as it does alternate the colors.

1 Like

Testing on windows now... (will edit shortly on results)
The last build you showed me had no colors so maybe that's a windows thing, but the arrow indicator greatly helped make it clearer what was being selected.

I'm thinking the red may need to be a little lighter to be comfortably readable on windows CMDs default black background, but we will see .. :slight_smile:

EDIT: Window version not appear to have processed yet - I will come back to this in a little while and update

Looks like I messed up the Windows build...

This one should work :crossed_fingers: (uploaded in 15-30 mins)

roger, will nab it when done

This seems broken on Windows 10 - the list is invisible (and selecting the area does not reveal anything either in case it was just a coloring problem)

Is there any way I can provide any debugging info for you on this?